LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter · #1 ·
So I have a weird starting issue with my 1997 trans am ws6 . Was told my battery was bad and causing it and didn't solve the issue. So normally when I try and start the car sometimes but not always it rolls over after cranking a few seconds like 7 seconds it's weird. But every time I put fuel system cleaner in my tank for about 2 tank fulls after everytime I start it it starts perfect like one second starts perfect right up. Anybody know what this could be. Need new injectors professional injector cleaner? Or nothing to do with injectors just don't get what causes this thanks. I use 91 premium only in the car. I'd use 93 premium but it's impossible to find in my area. Thanks
 

·
Global Moderator
Joined
·
13,464 Posts
We need to get some more info here. You have a starting problem. You replaced the battery.

So was your problem the starter not cranking engine over?

Or was starter dragging somewhat when cranking?

Or was starter turning over engine just fine and it not wanting to run?

This info will help to take a path in troubleshooting your problem.
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #3 ·
Engine wouldn't turn over right away. It basically cranks longer without the engine kicking in and starting to run it cranks for like 3 to 4 seconds. But when you put fuel injector cleaner in the car for a while like 2 tank fulls then it starts without cranking hardly at all u just turn the key and it starts in like less then a second
 

·
Global Moderator
Joined
·
13,464 Posts
First thing you need to do is get a fuel pressure gauge and hook to shrader valve on fuel rail. Turn key on and fuel pump should run for several seconds. Fuel pressure should be around 43 psi. Is it?

If no, turn key off and do another key on prime. Does fuel pressure rise to around 43 psi. If yes then fuel pump is getting weak & needs replacement.

If no, it's time to suspect clogged fuel filter, or filter sock on fuel pump pick up tube. Have you changed the large inline fuel filter? If no, do so now. This is a part that needs replacing from time to time.

Here's a link to the 95 factory service manual. It will help you figure things out. www.mediafire.com/?40mfgeoe4ctti

If changing fuel filter doesn't help, unfortunately changing filter sock involves either dropping exhaust pipes, rear end, & fuel tank. Or you can cut a trap door to make fuel pump work much easier. I will include a pic of where to cut.

But if you decide on cutting a trap door, be aware that you don't want to create sparks while cutting trap door.

If fuel filters & fuel pump aren't what's causing problem, clogged injectors are the prime suspect. Fuel injector cleaner only can do so much.
 

Attachments

·
Premium Member
Joined
·
20 Posts
So I have a weird starting issue with my 1997 trans am ws6 . Was told my battery was bad and causing it and didn't solve the issue. So normally when I try and start the car sometimes but not always it rolls over after cranking a few seconds like 7 seconds it's weird. But every time I put fuel system cleaner in my tank for about 2 tank fulls after everytime I start it it starts perfect like one second starts perfect right up. Anybody know what this could be. Need new injectors professional injector cleaner? Or nothing to do with injectors just don't get what causes this thanks. I use 91 premium only in the car. I'd use 93 premium but it's impossible to find in my area. Thanks
Keep putting fuel injector cleaner in the tank.. lol
 
1 - 5 of 5 Posts
Top