LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
277 Posts
Discussion Starter #1
Ok since i've bought this Trans Am last month 99 TA WS6, it never had either turn signal working cause of the bulb was rusty & the socket.

Left Turn Signal has the issue

So i replaced it with (Dorman Part # 85881 GM Rear Stop/Tail/Turn Light Socket) that is compatible with these cars. I installed the socket and new bulbs as we'll. Everything was working perfectly the first day both turn signals would blink as they should and stay lit etc.. Now only my right turn signal is on as it should be and blinking when it should. My left turn signal light is off when driving and when i apply the turn signal it doesn't blink. My dash turn signal light blinks normal. My left turn signal light does turn on when I lock/unlock the car but wont be on when the car is...

I think it's wiring but idk what to look at... What could it be?

If you need video to help understand let me know.
 

·
Registered
Joined
·
277 Posts
Discussion Starter #3
i replaced with new front turn signal sockets & new bulbs too... when i put the parking lights on the turn signal light is on. So i know the bulb & socket work... but it wont blink when i put the turn signal to engage the left signal..

could it be the DRL's?

EDIT: I am talking about the Front Left Turn Signal ...
 

·
Registered
Joined
·
772 Posts
The confusion here is that Dorman does not recognize this part as a replacement for the front sockets of our cars, so the description only says "rear". I confirmed the fit with help from another member, almost by accident.
 
1 - 5 of 5 Posts
Top