LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I barely ever drive my car since I live so close to school, I usually ride my bike, occasionally drive my car. Car usually runs perfect no problems. But lately and randomly I'll get a spike in water temp up over 210! I'll hit the fan switch and it helps a little but not a lot! Anyone have any answers or suggestions? I usually take back roads to avoid traffic and all that!
 

·
Registered
Joined
·
24 Posts
Discussion Starter #2
I did check under the car and the radiator and there are no grocery bags or anything like that caught up in there
 

·
Registered
Joined
·
221 Posts
Factory fan turns on at 215... big fan turns on at 225 or something rediculous... so yeah... also, for the sake of it, check you anitfreeze and make sure there is no air in the system.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
I've got a manual fan switch and I usually turn those on around 190 even tho I have a 160 Thermostat.....I doubt there is any air in there, my dad flushed out the coolant and radiator for me like a month ago and I know he always double checks for air bubbles and that crap. I'll check again tommorow, it's just bugging me it only happens at random times!
 

·
Registered
Joined
·
1,230 Posts
does this happen when your driving, my old 87(yea i know its not an LT1) would usually gett pretty hot if i sat at a long red light or sat idleing for while

all i did was pop it into N and give it a little rev, temp would come back down
 
1 - 5 of 5 Posts
Top