LS1LT1 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Ran my lt1 out of gas long story short I let it sit over night and it started right up.. it has a full tank of gas.. I was taking it down the road then it bogged out on me and died.. the fuel pump is still working cuz I can hear it ever time I turn the key.. I looked at fuel filter by taking the backside line off of it and the fuel came out the filter and I couldn’t see no gunk or anything clogging it.. I’ve gone through all the steps fuses etc... I’m completely fucking stuck here
 

·
Global Moderator
Joined
·
13,559 Posts
OK, pump is running & filter has fuel in it, have you attached a fuel pressure gauge to fuel rail and checked Key on prime pressure? It should be around 43 psi. If way low, engine won't run.

Does your security light come on when you turn key to on? If it lights & goes out after a few seconds, this is normal operation. If light stays on, you have a vats security problem. This will disable the fuel injectors. If security light doesn't turn on, you need to fix that problem.

To help you in your troubleshooting, down load the factory repair manual at the following link.www.mediafire.com/?40mfgeoe4ctti

The site has all lt1 manuals except 97. If you have a 97, the 96 will work just fine. It's important that you give year, model of your car.

Have you tested the ignition for spark? Have you scanned for codes? 93 -95 cars are obd 1 based. 96-97 cars are obd 2. The 4 ignition codes do not light the cel or ses, depending on year of car. These codes will keep fuel injectors from opening, and no spark. Except for high resolution pulse missing code. Which will let engine run.
 

·
Registered
Joined
·
40 Posts
Just a mild correction. Use the 96 if you have a 97. The 98 was when the F-Bodies went to the LS1
 
1 - 4 of 4 Posts
Top