LS1LT1 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Was driving car one day last year and would not shift out of 1st. Only 1st gear and reverse. I have it in a shop now and they pulled the pan and said solenoids are good but the tranny extremely dirty and time for a rebuild. Does this sound like fair advice? I did not have any problems that i can remember leading up to this.
 

·
Registered
Joined
·
1,070 Posts
Ask them what their theory is on what caused 2nd, 3rd and 4th to all die at once.

Band...? OK, 2nd and 4th gone.
3-4 clutch...? 3rd and 4th gone.
Sun shell? 2nd and 4th gone, but so would reverse...
Common cause for all three at the exact same time? Hmmm...

I think I would dig deeper. Is the PCM commanding a 1-2 upshift?
 

·
Premium Member
Joined
·
359 Posts
Did your speedometer stop working at the same time?

Frank
 

·
Registered
Joined
·
1,070 Posts
That's exactly where I was going with that...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I believe the speedometer was working. I did check with a local reputable transmission shop and they think it is an internal fault but they would need to test drive it to confirm.
I am looking at used transmissions for now just to get it going.
 

·
Premium Member
Joined
·
359 Posts
Before you go that route, put a scanner on it that's capable of reading data. Make certain the computer is seeing a speedometer signal. If the compter doesn't get a signal, the transmission will have no upshifts. While the scanner is on it, check it for codes.

Frank
 
1 - 6 of 6 Posts
Top