LS1LT1 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I own a 94 chev camaro lt1, Its kinda weird. It has 49k miles almost on the spot. And I never drive it. Well last week i started noticing, it doesnt accelerate good or idle good. Ive owned it for 3 days. I will add that the car did sit in my popz garage for almost 5 years. Ive added fresh gas. Ive checked out the website sometimes, but never thought i needed to joing until now. Any thoughts?
 

·
Registered
Joined
·
620 Posts
Welcome to the forum dude.

I would take off the fuel injectors and make sure they are giving a good spray instead of a bad drip.

Also, when your filling up make sure to use 89, 91, 93, octane gas. 85 and 87 isnt really too good for these cars (From what ive seen) Yea you can run it on 87 but it might not accelerate like you want it too and you might not get good gas mileage.

If your father's garage wasnt sealed, it was more of a outback no heat no ac kinda thing. like a barn,
Check your air filter, Make sure there isnt any little rats nests or anything crazy goin on there. I'd also check the MAF and make sure nothings been deposited there by little critter's. The MAF is by the way the little silver square on the black intake elbow.

Other then that with only 49k miles i really wouldnt expect it to be a fuel pump, or really even a fuel filter?
 
  • Like
Reactions: Jasonlovesvettes

·
Premium Member
Joined
·
5,014 Posts
if it had been sitting for 5 years without proper long term storage service, i am sure that the fuel tank is f#&cked, full of sludge, it will need to be drained and cleaned by hand.

after about 2 years fuel turns to a gross brown varnish.

the fuel filter will be clogged, the rails and lines will need to be purged

the injectors will need to be checked for spray pattern, and cleaned or replaced.

adding fresh gas will not resolve this situation. adding 'fuel system cleaners' to the tank will make it worse by dislodging the sludge.

the fuel pump itself is probably also in very poor shape at this point, and i doubt even if you clean the tank up, that it'll make proper pressure

mine sat for about 5 years in someone's yard on a half tank, the tank was so full of brown sludge that it instantly clogged all of the injectors. i clogged up 4 fuel filters even after i hand cleaned the tank twice

start by cutting a fuel pump trapdoor, removing the sender, and seeing what's in the bottom of that tank
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Fou.d the problem i had a injector that was clogged i cleaned it jp and now it runs fine .
My air filter is okay by the way. Thanks guys i will b taking the tank off to clean it as well along with the fuel p.
 

·
Premium Member
Joined
·
5,014 Posts
good plan, but do it now, cause if there's shit in the tank, you'll be clogging more of them really quickly

at the very least change the fuel filter asap...
 

·
Registered
Joined
·
620 Posts
Yea man, i miss lead you by saying i wouldn't think it was the fuel filter or fuel pump, i didnt think about it sitting for 5 years. My apologies, i would HIGHLY recommend doing everything, steveo has said to do. This guy knows the ins and outs of an F Body quite well.
 
1 - 6 of 6 Posts
Top