LS1LT1 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
As the title implies, new member here. I recently purchased a non-running frankincar. It is an 98 Jeep Cherokee with a LT1 in it. That is backed up by a built AX15 and Ford 9" in back.

The back story here is the previous owner was driving home and the Jeep just died. He coasted it into a parking lot and tried to start it. It idled rough and would rev very slowly. This was back in late dec. He didn't have the money to have a shop work on it, so it sat in his drive. I picked it up last week and am in the process of trying to get it going again.

The conversion was done 34K ago by Corvette Connection of Lee Co. The LT1 was overhauled at that time with .030 pistons, .010 rod and main brgs, 2.00" intake and 1.59" exhaust valves. Ported and polished heads, 1.6 RR and 22-4 cam. Plus it had full MSD opt, coil and wires.


When the conversion had 18K on the clock, the MSD opti was replaced along with the plugs. I have receipts from other services, but they don't seem relevant to what is going on with it.


I was informed that the entire assembly was from an 95 vette. The previous owner tried to scan for engine codes, but was using an OBDII scanner and couldn't get it to talk to the computer.


I went ahead and purchased an ALDI 16-pin cable and setup Tunerpro on my laptop. The cable came in yesterday and I decided to try and pull codes this afternoon. Unfortunately I can't get the tunerpro to connect to the pcm. So I can't pull the codes. With that route out, I just started poking around the engine bay. I ended up pulling the wire off the coil to find it full of oxidation. I cleaned that up and couldn't resist trying to start it. It fired right up. I tapped the throttle and the rpms jumped quickly. It ran a bit rough, but I don't know how much of that is the engine setup. I pulling three of the four plugs on the drivers side and they are all showing fouling which might be the source of the rough idle.

So that is where I am at on it. I was hoping to have codes and engine logs, but I am making due with what I know. Next step in my mind without the scanner working is checking the throttle position sensor, but over than that I am stuck. Any suggestions on how to proceed from here would be greatly appreciated.


I have some pictures and will update this post once I get the reset from photobucket
 

·
Global Moderator
Joined
·
13,567 Posts
Did you buy the aldl 16 pin cable specifically made for 95 obd1 cars, or did you buy a standard obd2 type cable? The obd1 and obd2 use completely different data protocols. Hooking an obd2 cable to your laptop is like hooking an obd2 only scanner to your car. It just won't read. www.aldlcable.com sells a 16 pin aldl cable made for the 95 f-body 16 pin obd1 aldl.
 
1 - 3 of 3 Posts
Top