LS1LT1 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My tranny in my 97 firebird/trans am is actin up. Its an automatic. When i floor it, it wont shift out of 1st gear unless i let up off the gas. I have heard that it might be a the TPS, Throttle Positioning Sensor. Any feedback would help. Thanx
 

·
Founder
Joined
·
7,472 Posts
Easy way to test the TPS is to hook up a scanning device and see if the TPS % reads correctly. How old is the fluid in there? How many miles? Lets eliminate all the other possibilities before we assume it means total teardown. I'd hate for him to spend $2000 to rebuild it and then come to find out that wasn't the problem.
 

·
Registered
Joined
·
288 Posts
i had a similar problem and it was the tps also. check that first, easy to install.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
well its got 105,000 miles on it. Tranny fluid is new. I went to a shop today and got it diagnosed. They are tellin me that the whole epav system is trashed. I pulled a hose from the evap solenoid, and the hose is full of dark black pebble-like little things. They told me at the shop that i would have to replace all the evap parts and blow out the hoses. Does anyone know anything about this or has it ever happened to anyone.
 

·
Founder
Joined
·
7,472 Posts
Shift speed and shift firmness are calculated based off of load. Load is calculated by the PCM using TPS% WOT shifts are also governed by the TPS as is WOT mode in the PCM itself.
 
1 - 10 of 10 Posts
Top