LS1LT1 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter · #1 ·
Just fired up my 383 for the first time. Runs great but I have the weirdest leak. I have a fuel leak that has me baffled. I hot wired the fuel pump to prime the system and set the FP Regulator to the correct setting. Pump ran for several minutes....no leaks.

Start the engine idle smooths out and all seems good until I notice the puddle of fuel under the car. Go underneath and fuel is dripping down of the starter and trans bell housing. Shut the car off fire up the fuel pump.....no leak....Start the engine let run for a few minutes......fuel leak. For the life of me I can't seem to find where its coming from and why only when the engine is running. I checked the fuel rail and intake and nothing appears to be wet.

Basic terms:
Fuel pump on + engine off = no leak
Engine on = leak

Am I the only one who had experienced this and if not can someone offer some assistance.
 

·
Global Moderator
Joined
·
13,437 Posts
The one part of the equation that changes with the engine running would be the fuel injectors. They are not leaking when closed, but when engine is running and injectors are opening and closing rapidly, one or more injectors could be leaking. O-rings would be primary suspect.
 

·
Registered
Joined
·
1,156 Posts
find the leak...or engine fire can easily be had with leaking gas.

as suggested confirm your injectors are seated correctly with good O rings. also confirm your FPR is not leaking at the line connection
 

·
Registered
Joined
·
119 Posts
Discussion Starter · #5 ·
Just a brief follow up. I did find the leak. It was the Fuel Pressure Regulator. Thanks you everyone for your help.
 
1 - 6 of 6 Posts
Top