LS1LT1 Forum banner

161 - 172 of 172 Posts

·
Registered
Joined
·
4,313 Posts
Discussion Starter #166
Finally made it to the track for first time testing with nitrous. Car ran perfect but I need to adjust a few things like suspension, tire pressure, colder plugs, and more tuning for my 9.9 ET goal. All in all a great learning session and not bad I ended the day with a 10.24 @130 MPH for a new best. Oh yeah, tires were spinning off the line so I didn't turn the nitrous on till after the 60ft mark.

https://www.youtube.com/watch?v=QgEkvm1FSik

https://www.youtube.com/watch?v=aWN97VshHZM
 

·
Registered
Joined
·
495 Posts
Wow! That's probably some kind of record i'm sure. What did you remove to lose 90 lbs?
 

·
Registered
Joined
·
4,313 Posts
Discussion Starter #171
Actually I was including my whole exhaust in that 90lbs but I forgot that I tried that already so it was more like 50lbs. I went manual steering rack, rear bumper support, and a bunch of small stuff.
 

·
Registered
Joined
·
4,313 Posts
Discussion Starter #172
Haven't posted about this car in a while, been busing with a new project. I'm still running the same setup, six years on the engine and five on 4l80e, both still going strong. Drove the car an the street more this year than in years past. Also, did some more experimenting with the nitrous late October 2017 and ran a best of 10.1 @ 135 MPH. Traction was terrible so I couldn't turn the nitrous on until after the sixty foot. This year I will get that 9 second run I've been shooting for. Had a few problems last year like opti (ending up putting stock original back in) and a broken rear sway bar link but all in all the car is still killing it. Here's a shot at the strip with the broken link.
 

Attachments

161 - 172 of 172 Posts
Top