LS1LT1 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Alright I have a 96 Z28 and it misfires. At startup it will idle fine and during the engine being cold, but once it gets to operating temperature it will begin to misfire throughout acceleration. If I throw it down say in 3rd gear and punch it, it runs fine and no misfire and seems to have alot of power. But also when I launch through first it seems fine but when I hit second and get to a high rpm it's like its reving high but the wheels arent turning while it's in gear. I think alot of people call this cam surge, like if I stop and it still idles at 2K then drops slowly. I don't know what the prob is. I replaced the Opti, Coil, Wires, Plugs, and it still does it. Even tuned the valves. I dont know if the cam is worn out or the lobes got flat but I need some help. This could be anything, maybe even a bad harness or PCM or vac leak. Well if anyone can help or has any suggestions let me know. Also it had a code P100 not too long ago that I deleted and it never came back but I tested the MAF and it wasn't bad. 972-679-5322
 

·
Founder
Joined
·
7,472 Posts
Well its not cam/valvetrain related if it only happens when warm.

If you had wiped a lobe or dropped a lifter then it would do it all the time.

What about fuel? Have you checked fuel pressure? How old are the injectors. Could one be bad/clogged? Fuel filter?
 

·
Registered
Joined
·
3,943 Posts
I'd say you need a full tune.

My cam does the "hold at 2k and then drop slowly" thing too. The more we've tuned it, the better it's gotten.

I suggested a tune b/c you might be leaning way out at high rpms. That would cause it to stumble up top.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
It sputters, backfires, and jerks after it gets to about 180. If I just start it up and take off fast its fine and it doesnt seem to lack power. Anyway to test injectors etc? I have a tune but it's so old, wanna stop the stumbling and backfiring before retune. Also if I raise the hood and while setting in the car I can see some like waves in the air above the motor like gas in the air. Maybe i have a lean misfire, because of vac leak or bad injectors? I replaced basically the whole ignition. Thanks, help more please.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Someone told me it could be o2's.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
I guess I'll have to ask Jeeves.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Well you see the diff in my car and others is my CATS and EGR are deleted from my PCM and when I get it inspected it still passes because it will read as ready, the o2's are kinda the same way but aren't deleted, it's like the car is using the tuned o2 data but even though if the o2's are bad it will run like shit because it uses the o2's with the tune. It's hard to explain but the tune made it where it won't throw a code for that but I unplugged the front two sensors and it runs like a champ now so I believe that was the prob. Thanks
 

·
Founder
Joined
·
7,472 Posts
Could be the 02's are reading way rich and the car runs fine in open loop, but then when warmed up and it hits Closed Loop the O2s are saying add fuel when its already too much.

BTW you can't delete the front O2s as you have to have them for the car to run in closed loop. If there's any deleted O2s its your rear O2s, which have zero effect on fuel delivery, they're there just to make sure the cats are functioning.

It runs like a champ now because you're forcing it into open loop all the time now.
 

·
Registered
Joined
·
247 Posts
I think I could be some type of fuel issue. :streetrac
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Chris 96 ur right. So if I replace them it will be fine? Or can I take my rear o2's and put them in the front? Thnx
 

·
Registered
Joined
·
44 Posts
sounds like a problem i have, car is fine until it gets warmed, then say when i am tring to keep steady rpms ie the interstate it will misfire, jumping up and down rpms, i replaced the plugs, this is really fustrating
 
1 - 12 of 12 Posts
Top