LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
Hey new to the forum but have been reading threads for years to help me out with my car and its helped immensely.

Any ways i just did a radiator swap on my car with a ZAP Racing aluminum 2 core (ebay). Fits great and cools good but it didnt have the hookup for the oil cooler and another hose thats just under the overflow i believe. i blocked the them off just so i could get home car ran great right under 180 degrees, im just worried if im going to cause any damage with those hoses blocked off and what they went too also as the aluminum one i bought did not have it.
Thanks and any help or comments are appreciated
By the way its a 1994 z28 6spd if that helps with any thing.
 

·
Registered
Joined
·
807 Posts
I dont believe your car needs an oil cooler,as in crankcase oil. I am not that familiar with the Camaro side of stuff. I am sure one of the camaro guys will give you a good answer. ed
 

·
Premium Member
Joined
·
5,014 Posts
the oil cooler lines should be run to an external oil cooler if your new rad doesn't have that. a small "transmission cooler" would be fine too. you don't really NEED an oil cooler, it's just a good idea, and they're cheap.

the other one is the steam pipe line, if the rad you bought doesn't have that connection, you might have to drill 'n tap to make that happen. it's critical that is reconnected, it's part of the cyl. head cooling system...
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #4 ·
It has two holes on the radiator for what i think is a tranny cooler but could i use those for the hose thats in the cylinder head and oil cooler? i looked on a diagram from shbox and i guess its called the steam pipe right? It looked like it brings coolant to the radiator and oil hose takes coolant away, could i use the top whole for the cylinder hose and the bottom for the oil cooler? Sounds like it might work. I just dont want to have those hose blocked completely
Thanks for the fast replies
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #5 ·
Also would i be able to use the hole for the coolant level sensor, i read a lot of people block that off too, i could try to use that hole for the steam pipe atleast as that is the most important. If the other two wont work ofcourse.
 
1 - 5 of 5 Posts
Top