LS1LT1 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Well I just got a 97 trans am non running car lt1 auto somebody has been in the wiring pretty good ive already ruled out vats its already been bypassed but for shits and giggles I replaced the resistors (I trust no one) still no start found some crispy wires at the ignition switch replaced wires and news ignition switch still no start, starts on ether so I got spark I have no fuel pressure or prime, bypassed fuel relay and the pump works still wont fire when cranked im sure im missing injector pulse, previous owner said it was blowing the computer fuse then stopped blowing it im thinking I need a new one but im not ready to condemn my computer, im not the sharpest tool in the shed so I figured I would ask some good ole boys for help, got a case of beer for whoever gets the right answer on this one, I got the ecm pinout and im gonna start checking power and grounds, also one thing I noticed is the service engine soon light doesnt come on prior to starting or after cranking possibly blown? I have no scan tool but I have a feeling I should get one any help or suggestions will be greatly appreciated

ALL I WANNA DO IS GET SIDEWAYS
 

·
Global Moderator
Joined
·
13,428 Posts
Your feeling is right, get a obd2 scan tool, one that does codes and real time sensor data. The sensor data is for future when it runs.

Next, go to 4th gen section. Look for thread titled "GM service manuals". Open thread, click link, download 96 factory service manual. It's 99.9% the same as your 97.

You will want the wiring diagrams, engine controls section, etc. In the manual, though you will have to search for it, is a pcm symptoms chart that lists the symptoms that each pcm wire cause if connection is no good. Very valuable tool.

Next is some actual troubleshooting. Rig your fuel pump to run by using the fuel pump prime connector on passenger side inner fender. shbox.com has a pic. You need to pull your fuel rails up with injectors out of intake. This way you can see if injectors are opening. Have assistant crank car and watch for fuel spray. SAFETY FIRST, have catch jars under injectors and fire extinguisher handy.

Run scan for codes. If you have low resolution pulse missing for opti, or 2 different icm codes, pcm will not allow fuel injectors to open. So you might want to scan first before removing fuel rails. It will save you some time if those codes are present. That is 1 reason for no fuel.

Need to fix the service engine soon light so it works. Last owner probably took bulb out to help sell car.

Get a spark tester, the kind that puts a load on ignition system to simulate compression pressure of cylinder. A spark that will jump the plug gap in free air will many times fail when spark tester is installed.

Do the tests, give the patient 2 aspirin, and get back to forum with the results.

You may end up having to do some in car and engine compartment wiring to get her going again. Start reading and learning the wiring diagrams.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Update got it started missing power to ignition positive at the ecm (black connector pin 30 pink wire) ran jumper wire started then died still no fuel pump power bypassed the relay and it runs haha now I just gotta back track the wiring

ALL I WANNA DO IS GET SIDEWAYS
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Well got a new problem drove the car down the road and it has no power, it moves itself but just doesnt have any get up and go runs great at an idle revs up good when not in gear also when you try to do a brake torque it wont spin the tires and then when you let off the brakes it feels like it loaded up and slowly comes out of it but still doesnt have near the power it should any suggestions
 
1 - 6 of 6 Posts
Top