LS1LT1 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
First off yes I replaced the flasher relay!! I converted all my lights to led and bought an aftermarket flasher relay and the turn signals stay lit like the bulb is out however it will flash when I turn the hazards on. :werd:
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #2 ·
Looks good just have to manually make them blink
 

Attachments

·
Registered
Joined
·
80 Posts
Discussion Starter · #4 ·
I'm thinking it has something to do with the flasher relay cause it has a ground lead and it wouldn't do jack without it grounded. If anything I'll put the regular bulbs back in and the stock relay and see what happens. Thanks for the help
 

·
Premium Member
Joined
·
5,014 Posts

·
Registered
Joined
·
366 Posts
i totally agree, ive ran many led bulbs in the past, get an electronic flasher, got mine at autozone, big yellow one called "loud" problem solved

the factory flashers use electrical resistance to build up heat on the switch inside which turns it on and off as its heated and cooled, leds do not draw enough current to cause resistance in the flasher

and do not use resistors, unless you solder them in, they always come loose and you will get hyperflash or it will stop flashing, then suddenly work again
 

·
10 Second Opti Club
Joined
·
6,736 Posts
You replaced the hazard relay, not the turn signal relay. You have to drop the panel under the steering wheel and its a few inches down from the rear defrost button. Napa carries the electronic flasher.
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #9 ·
You replaced the hazard relay, not the turn signal relay. You have to drop the panel under the steering wheel and its a few inches down from the rear defrost button. Napa carries the electronic flasher.
Is there two under the dash the one I replaced was almost by the trunk button. Working out of town right now don't have it with me but hopefully it'll work
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #11 ·
So do I need another one to make my hazards work?
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #13 ·
Turns I had only found the hazard relay I moved it to the turn signal one had turn-signals no hazards bought another relay and put in in the hazard spot and have both now! Thanks you guys are awesome!!!!!!
 
1 - 14 of 14 Posts
Top