LS1LT1 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter #1
Anyone know?

I have the cover but no bolts for it.

tia
 

·
Registered
Joined
·
138 Posts
My transmission bottom cover wasn't machined threads. Looked more like wood screw threads instead.

Is it the metal inspection cover that covers the bottom half of the transmission or a solid bell housing and you are talking about the small plastic covers
 

·
Registered
Joined
·
265 Posts
Discussion Starter #3
Yea it covers the Torque Converter/Flex plate. Mines sheetmetal with 4 bolt holes. I took it off last year and lost the bolts but haven't worried about it too much.

But my son's new girlfriend has a dirt road with grass middle strip and last time I went there in the Maro, I started mowing that strip which isn't a bright Idear :p
 

·
Registered
Joined
·
138 Posts
Forgot mine probably had 4. But they arent machined threads like normal bolts. 8 or 10mm hex head but they looked like wood screw type threads.
 

·
Registered
Joined
·
265 Posts
Discussion Starter #5
We got it figured out.

Neighbor brought over his tap and die set.

They are 3/8 -16 bolts. Had the wife pick some up and it's back on.

Thanks :)
 

·
Registered
Joined
·
1,070 Posts
They are metric bolts, not SAE. They should be M10x1.5 if it's an LT1 case.
 

·
Registered
Joined
·
265 Posts
Discussion Starter #7
Yup you're right. I had my son doing it and I shoulda double checked him. Went to put the bolts in and too small so whipped out the tap and die again and M10x1.5.

Thanks
 

·
Registered
Joined
·
1,070 Posts
Yup you're right. I had my son doing it and I shoulda double checked him. Went to put the bolts in and too small so whipped out the tap and die again and M10x1.5.

Thanks
:thumbsup:
 
1 - 8 of 8 Posts
Top