LS1LT1 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all I hope I’m posting in the right section as I am a new member. Not sure if I need help or just reassurance that my suspicion is correct. So I’ll start here last summer I was changing the plug wires and when removing the plug that goes from the coil to distributor the cap broke (dry and brittle) So I decided while I was in there I might aswell change the whole unit spent 120$ on a new one (which is where I think I went wrong) anyways I completed the job and the car drove fine for a few weeks then one day started to sputter and back fire and then it just died towed it home changed the coil and icm as I had fuel and spark wasn’t sure if spark was strong enough that’s why I changed coil and well to be honest I was hoping it was anything but the Chinese dissy. so I am here to see what you guys have to say is there anything else that could be giving me these symptoms?
 

·
Global Moderator
Joined
·
13,372 Posts
Welcome to the forum.

Yes, your problem was buying the China made opti. 50-50 chance of being bad, right out of the box. And 50-50 chance of failure within a few hundred miles. If your lucky enough to get one that works right out of the box.

If your going to keep a lt1 equipped car, you need an oscilloscope to test the opti low & high resolution pulses. You can buy a PC based scope for around $70 on ebay, amazon, etc.

Buy a rebuilt GM, Delco, or Delphi opti. They are the best of a sorry lot. I've also heard that a Petris opti is pretty good. But it's near as expensive as the oem one's listed above. And I don't personally know anyone who has bought one. But if your willing to be the test piolet, grab a Petris opti and try it.

Also grab the 95 factory service manual at the following link. It has tests, codes, wiring diagrams, and other good stuff.
www.mediafire.com/?40mfgeoe4ctti

Also check out the Shoebox site. It has loads of good lt1 info. www.shbox.com
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome to the forum.

Yes, your problem was buying the China made opti. 50-50 chance of being bad, right out of the box. And 50-50 chance of failure within a few hundred miles. If your lucky enough to get one that works right out of the box.

If your going to keep a lt1 equipped car, you need an oscilloscope to test the opti low & high resolution pulses. You can buy a PC based scope for around $70 on ebay, amazon, etc.

Buy a rebuilt GM, Delco, or Delphi opti. They are the best of a sorry lot. I've also heard that a Petris opti is pretty good. But it's near as expensive as the oem one's listed above. And I don't personally know anyone who has bought one. But if your willing to be the test piolet, grab a Petris opti and try it.

Also grab the 95 factory service manual at the following link. It has tests, codes, wiring diagrams, and other good stuff.
www.mediafire.com/?40mfgeoe4ctti

Also check out the Shoebox site. It has loads of good lt1 info. www.shbox.com
Thanks i appreciate the fast response lol you can probably tell not too excited do be doing this over again but I figured that was my problem. not sure I want to be the test pilot worst part is I read that the Delphi and Delco was the way to go prior to buying the junk but couldn’t afford that at the time and now it’s back to bite me in the a$$. So I will definitely take your advice and thanks for the links
 

·
Global Moderator
Joined
·
13,372 Posts
Also, there's a free 4th gen camaro parts book out there in pdf forum. Do a google search and you should find it.
 

·
Premium Member
Joined
·
6 Posts
Hello all I hope I’m posting in the right section as I am a new member. Not sure if I need help or just reassurance that my suspicion is correct. So I’ll start here last summer I was changing the plug wires and when removing the plug that goes from the coil to distributor the cap broke (dry and brittle) So I decided while I was in there I might aswell change the whole unit spent 120$ on a new one (which is where I think I went wrong) anyways I completed the job and the car drove fine for a few weeks then one day started to sputter and back fire and then it just died towed it home changed the coil and icm as I had fuel and spark wasn’t sure if spark was strong enough that’s why I changed coil and well to be honest I was hoping it was anything but the Chinese dissy. so I am here to see what you guys have to say is there anything else that could be giving me these symptoms?
If you plan on keeping the car invest in TorqHead's 24X sysyem and get rid of the optispark headaches forever, and as a bonus includes 25 to 50 HP and Torque gain plus an OB11 computer system.Check it out.
 

·
Registered
Joined
·
2 Posts
If you plan on keeping the car invest in TorqHead's 24X sysyem and get rid of the optispark headaches forever, and as a bonus includes 25 to 50 HP and Torque gain plus an OB11 computer system.Check it out.
I have been using Torque since 2016 with no problems. Its really a good system.
 
1 - 6 of 6 Posts
Top