LS1LT1 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
Thanks for having me
. I scored a 51’ merc a few year back with what believe to be a 94lt1/4l60e 88-95 blk number . The previous owner has since past away so it’s perplexing and I am finally getting to the drive train . I want to post pics in a proper forum tomorrow discussing it . It does not ! have the optispark . It is running tpi and rear distributor and regular sb water pump . Heads are water fed .. I will post pics tomorrow in correct forum because I’m very confused ( I read about the fizzy setup ) .. thanks for having my along
My name was supposed to read 51merc sorry so I’m 51meec lol
 

·
Global Moderator
Joined
·
13,060 Posts
Welcome to the forum.

Sounds like a perplexing problem to me also. Hope we can help you get a handle on things.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
I think it has the manifold mod to swap to the rear .. I will take pics today . I haven’t heard it run but I know it did and this mod was to ditch the optispark as I’m told . I have zero experience with the lt1 optispark
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
I think it has the manifold mod to swap to the rear .. I will take pics today . I haven’t heard it run but I know it did and this mod was to ditch the optispark as I’m told . I have zero experience with the lt1 optispark
 

·
Global Moderator
Joined
·
13,060 Posts
I have answered in your other thread. But engine is not a lt1. It's a 305 or 350 tpi engine from 85-92 camaro & firebird.
 
1 - 6 of 6 Posts
Top