LS1LT1 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
I've been getting a nasty squeeling noise under the hood the last little while. Serpentine belt is new from last summer, and is still in good shape. I'm going to repack bearings (probably needs it anyway), but while trying to pinpoint the source of the squeel, I noticed my harmonic balancer isn't true..

I have other issues, one of which is a nasty shudder at partial throttle under load on the highway. I was wondering if the shuddering might have loosened the balancer, or tweaked it somehow.. I haven't had a chance to get in there and torque it down (hoping the weather on the weekend co-operates), and obviously a replacement balancer/hub may be in order, but it got me thinking whether cause/effect is reversed - can a wobbling balancer be a source of my shuddering?
 

·
Registered
Joined
·
1,156 Posts
the harmonic balancer should not wobble and certainly can result in your car "shuddering".

The rubber on the balancer may be old/cracked causing this. A replacement balancer is needed. you can unbolt the balancer from the hub to replace
 

·
Registered
Joined
·
28 Posts
The balancer isn't to bad to get off, if you a haynes manual it will tell you you don't need a puller but a puller makes it a whole lot easier. Definitely check the wobble with the belt off before you take the balancer off then check the hub after the balancer is off to make sure the hub is ok.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #4 ·
Thanks for the advice guys - any easy way to check if the hub is ok?
 

·
Registered
Joined
·
1,068 Posts
Please trouble shoot why your balancer is wobbling first. Yeah it could just be a balancer or it could be worse and yes the best case senario is the rubber is bad. For a replacement Balancer check out Professional Products. They have good balancers and they are affordable. Obviously I would use a PP Balancer on a $12K engine built for balls out racing but you should be fine. Also a WOT shudder could be a number of things but likely an ignition issue. Just my 2cents. Good luck!
 

·
Registered
Joined
·
1,156 Posts
it is much more common for the rubber to break down in the balancer itself and start to wobble than the hub being bent

as noted pull belt and see if damper spinnning wobbles. If so remove just the outer balancer and start engine again and see if hub has a wobble in it.

the wobble is a sign of part failure which may or may not be related to your shutter but certainly a suspect so fix it and move on from there if you still experience shudder...which could be many things with ignition issues being one I would look at next.. If thse check out pull dust/inspection cover from torque converter and inspect flexplate for cracks. you will have to rotate the motor to see all of the flexplate under those conditions and it still may be hard to see if in fact it is cracked.
 

·
Registered
Joined
·
87 Posts
Just replaced my balancer today as I had this same issue. Saw the wobble and noticed cracking. Problem fixed now. Easy quick fix for $65 bucks!
 

·
Registered
Joined
·
112 Posts
After removing the balancer. If you have a dial indicator you could slowly spin the crank and measure any runout. If its bent, I may have a spare hub for the price of a couple beers and tuning access for my camaro. I also have a dial indicator if needed
 
1 - 8 of 8 Posts
Top