LS1LT1 Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #22
? How would that increase fuel pressure?
Sorry for the confusion. In one of my previous posts (post #10), I mentioned my car stopped running altogether. The reason for that is one of the connectors on the fuel pump broke off, so they needed to replace it again. I also hope they fix the fuel gauge reading issue (expecting the car back today).
 

·
Registered
Joined
·
204 Posts
Discussion Starter #23
Got the car back, everything is good now.

Only strange thing I found was on the invoice -- they claim the fuel supply hose popped off and was "warped". Anyone else heard of the supply hose warping? Just concerned because I do not want this to happen again.
 

·
Spelling Bee winnah!
Joined
·
5,018 Posts
I had my fuel pump replaced four years ago or so and the hose popping off happened to my TA also. Mine popped off also during first prime also due to the plastic clip piece breaking off in the tank. When you said it stopped running that's what I figured may have happened. It seems they did you right by just saying the part was faulty and replacing the whole thing.

My old mechanic at the time just tried to throw the hose back on while trying to re-clamp it himself, probably with a stainless band or something stupid. It worked for a little bit so he sent me on my way stating that, "It's fixed." Well this time my pump died on the highway right after I picked it up. I had to wait for a tow and sent the tow truck back to the shop. When I called him he was avoiding me because at this time he was going to eat labor twice, dropping the tank, and needed to catch up in the shop, bad mistake. I ended up getting really pissed off and just drove down there. After some stern arguing with him he admitted he put the hose back on hoping he didn't have to get another pump and that the pump he bought ended up being some cheap chinese piece of shit cause he's cheap. This time he ordered me a more superior part and I never had issues with it sense. He did end up eating all costs minus the first charge, he even ate towing. To say the least I don't send cars out there or recommend them to anyone but I do purchase misc parts off of him because he gives me a nice discount and now he knows I don't want cheap chinese remanufactured parts.

IMO, the shop did you right. If they didn't give you grief the second time around and tried to answer your questions as best as they can then they did you well. In addition, if they paid for the all the costs the second time while eating the tow and ended up replacing your pump with a whole new one then that's a huge bonus in my personal experience. Also they did NOT cut a hole in your car, that would piss me off if they did.

The LS1 getting confused with an LT1 is far too common I think with these cars. The chassis are the same and they are both 4th gens even though the mechanical components aren't similar. Being Fbody enthusiasts it seems silly to us but to them I doubt they see many Fbodies in the shop anymore. Thankfully they went off the VIN instead of what they thought they knew.

As for an LS1 pump being replaced with an LT1, no you can't do it without modification.

As for the hose warping I'm not sure what they are talking about. Maybe when it blew off the pump and bent it in some way? You might be able to ask to see the old/new pump and ask them what they were talking about. I know in other aftermarket pumps like Racetronix one of they things they boast about is their hose being better than stock replacements.

Anyway, glad to hear everything is probably worked out on your car!
 

·
Registered
Joined
·
204 Posts
Discussion Starter #26
xDetroitMetalx,

Wow, what a story! And yes, I am happy to say that the dealer was extremely apologetic about the situation and literally offered anything to assist me with the situation (arranged the tow truck, kept me up-to-date on the repairs, and even kept the car inside at all times when closing for the day).

They gave me absolutely no grief (again, they really felt sorry for me that it didn't work out the first time). The pump came with a lifetime warranty (which apparently includes labor as well). And as an extra bonus to me, they even replaced my fuel filter at no cost! :thumbsup:
 

·
Registered
Joined
·
5 Posts
Hol
Well, I now have a much bigger issue to deal with.:craz28:

Now the car will not start at all! Had it out this morning, came back home. Was about to go back out, and now it won't start up (cranks but won't fire up).

Needless to say I already called the dealer to arrange for a tow truck to pick my car up and fix it. Also mentioned the gas gauge issue is still not fixed either (gauge read 1/2 this morning when I filled it up, it took just under 5 gallons).

EDIT - Fuel pump did prime for 2-3 seconds as usual when I turned the key on.. Hold to the floor. Lol. Pin it.
 
21 - 27 of 27 Posts
Top