LS1LT1 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
I have a 94 z28 manual trans and struggling with a high NO and high (although borderline on both) fail for CA smog.

has a missfire under load - replaced plugs and both o2s (OE ACD) fuel filter / egr valve and egr silonoid

I recently downloaded SCAN9495 ( I can not figure out how to attach them to this post) no CEL not sure how to read all the data that the data logs pull.

Based on the High NO assuming a little lean and from what I am seeing on posts a lean mis-fire can raise HC.

I recieved a recomendation of a CAT as it is original and very old, but wanted to know thoughts or if I should consider fuel regulator or pump having an issue. All stock outside of a KNN air intake - if someone can read and understand the data log on a scan9495 I am happy to send you some files to peak at.


Hoping to get this thing to pass smog soon - son loves the car but in California tight emission restrictions even on older models.

Thanks for any help that can be brought
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
good eye on that - I looked back at the data logs and they both seemed to move up and down a lot not sure how that freeze frame was.

Not sure if anyone has scan9495 that is willing to look at data logs if I send them?

Thank you

Toby
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #9 ·
small update - checking for vacuum and exhaust leak and found driver rear exhaust bolt not their (prob broken off as if feels that way and I can not get a bolt in)

Although most posts I read state that a ex manifold leak would more often cause it to run rich as the 02 would read lean and add fuel? Not sure if an exhaust manifold leak at the head would cause a lean condition that I am fighting.

thanks for reading and for any input that you may have on the concern
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #10 ·
the oxygen sensors are ACDELCO and new, but I disconnected 02 and miss went away, drives amazing - not sure if the oxygen sensors are reading wrong? I see some posts showing NGK as a good 02, but I believe the acdelcos are now a NGK rebox?


Not sure if something is causing the 02s to read wrong or if they are just reading wrong.
 
1 - 10 of 10 Posts
Top