LS1LT1 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Hey Guys

Yes, me again. After a longer time of no more issues, the Lady starts to give me a hard time again. Here is what happend:

I was gonna get my Laptop, drove down the road as usual. I did not seen any sign of problems and then I noticed: Check Gauges. I was like "What the..." So I noticed "Water Temp" was extrem high, and she started to buck like a horse (Out of nowwhere). So I turned her off, let her cool down a moment and drover her to my friends house and let her cool off. I noticed the radiator hose had a smal crack and was hissing...no water left at all. I do not drive her tomorrow, I call my friend with his Towtruck and bring her over in the shop...I just hope nothing else is going on. I mean I thought about a new engine a couple weeks ago, just for the fun of it, and layed some money to the side, just in case...you never know. That was 6 months ago, and I hope I do not have a blows gasket or whatever here. Anyone here been to a problem like that before ??? This is just wild...never seen anything like this before...it is a drawback, because I thought I just had her going right and was gonna give her a paintjob.

Just in case: Anybody here has a website where you can buy good used V6 3.9 engines or rebuild ones ? Like I say, I do not wanna get a bad vibe arround me, but I just wanna be prepared if it comes to the worst case.
 

·
Global Moderator
Joined
·
13,110 Posts
98% of the time, if you catch an over heat quickly you won't toast the engine. However, with aluminum heads any over heat can cause them to warp and blow a head gasket in the near future.

So keep an eye on that.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
98% of the time, if you catch an over heat quickly you won't toast the engine. However, with aluminum heads any over heat can cause them to warp and blow a head gasket in the near future.
Yeah I will :) Like I say, in the best case I have money for a used engine, but I do not think that will be the case :)
 

·
Registered
Joined
·
86 Posts
Discussion Starter #4
Allright guys, problem is solved, I was very Lucky. I replaced all parts and she runs now even smoother then before :)
 
1 - 4 of 4 Posts
Top