LS1LT1 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
900 Posts
Discussion Starter · #1 ·
Hi all. I recently bought a 95 Trans Am with LT1 and I was wondering why both of the cooling fans turn on right after i fire the car up, Even if the car is cold. I live in Massachusetts so it gets pretty cold around here. Are the fans programmed through the computer? How would i know if the stock program has been changed? Any input would be great. Thanks.
 

·
Registered
Joined
·
1,473 Posts
Is the check engine light on? Sounds like it's in maintenance mode. The fans are on high right?

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
900 Posts
Discussion Starter · #3 ·
No, the check engine light is not on. There are no trouble codes present.
 

·
Global Moderator
Joined
·
13,567 Posts
could be last owner wired up the fans to run whenever ignition switch is on. Check fan wiring diagram at shbox.com and see if your fan wiring is factory or not.
 

·
Registered
Joined
·
900 Posts
Discussion Starter · #5 ·
They do not turn on exactly when the ignition is hot. they come on about 5 seconds after car is started. i'll check out that site. thanks.
 

·
Registered
Joined
·
1,473 Posts

·
Registered
Joined
·
900 Posts
Discussion Starter · #7 ·
No, the ABS light is not on.
 

·
Registered
Joined
·
13 Posts
I kinda have a issue like this except my fans come on when i turn the heater on. i live in Wisconsin so of course its cold but even if i turn the switch real fast past the A/c the fans still come on.
 

·
Registered
Joined
·
13 Posts
sounds to me like someone has disabled the check engine light. To test the light pull the Air Pump fuse under the hood. This should make the light come on. If the light don't come on that is the problem.
 

·
Registered
Joined
·
900 Posts
Discussion Starter · #10 ·
Would the light come on immediately?
 

·
Registered
Joined
·
13 Posts
It takes a few minutes for the light to come on. drive it aroud the block or something.
 
1 - 11 of 11 Posts
Top