LS1LT1 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey first time poster here... Any help would be greatly appreciated.

My 94 lt1 z28 (115000miles a4) died on me on the way to work the other day, I managed to get it home and checked the codes in in freescan.

It threw 16, 36, 18, 41 and 42.

So I replaced the opti, icm, coil and water pump the next day, along with an included opti harness.

Started the car with no problems after the installs, let it run and before I took it for a test drive I checked the codes again.

Low and behold it was throwing 16 again, I cleared it and it popped up once more. I know this is suppose to indicate opti, but I hadn't even put a mile on it.

I've since put about 100 on it, running strong without issues besides some possible pinging and a known exhaust leak. Regained a lot of power that was being squandered from the last opti missing.

So my question is what do I do with this lingering lo-res code? I don't want to be stranded yet again.

Any help would be appreciated.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
It is a richporter, i had to go with what I could get in it that day, it's my daily driver.

The reason I replaced the coil and icm is because it had a really odd problem where the key wouldn't turn in the ignition unless I forced it, then afterwards the car would misfire like crazy until I restarted it. It would only do it sporadically, I had no idea what could cause that, so I did it all at once.
 

·
Global Moderator
Joined
·
13,437 Posts
Cheap optis have over a 50-50 chance of failure failure right out of the box. Sure the company will give you another one. But how many times do you want to change the opti before you get a good one.

Then you have a 50-50 chance of the running opti failing within a few thousand miles.

Do yourself a favor and stick to GM, Delphi- which is a GM company, or MSD.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5 (Edited)
I bought an off brand knowing that poor quality was a possibility, and I could accept right out failure or bad running condition and cut my loses.

But what's happening is the cars running better than ever, with zero code 16 symptoms.... But I'm still getting code 16, so aside from crossing my fingers re-replacing the opti and hoping that was the cause.... What other options do I have?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Could the pinging be related to the code? Is there a better program I can use to diagnose this other than freescan?

Where would I start with pre detonation anyway?
 

·
Global Moderator
Joined
·
13,437 Posts
You can download the trial version of DataMaster at TunerCat Where DataMaster rocks is the fact that when you do a running sensor scan, it puts the data in a file that can be played back in real time.

That way you can upload the file to a file sharing site, link it back to the forum where members can help you find the problem.

DataMaster comes with 20 free scans and unlimited data playback.

Also, in the 4th gen section sticky threads, we have another obd1 scan program written by member GaryDoug. It's called scan9495 . Where it rocks isthe ability to not only do running sensor scans, read regular codes, it will also read ABS and SIR codes. No other obd1 scanner that regular people can afford does that.

If you would like to learn about scanner readings, PM me with your e-mail address and I'll send you the pdf file of "scanner readings and what they mean". It will help you understand how the pcm controls your engine.
 
1 - 8 of 8 Posts
Top