LS1LT1 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Hey Guys

I have this problem for a while. After the last time the car was standing it went a away but since the engine work is done and I drove it every day it is back. My clutch pedal return spring makes a noise. Almost sounds like if somebody opens and closes an old screendoor with a rusted spring. I have no idea if they can worn out or something, but it is gettin to a point where that noise is gettin on my nervs.

Lars
 

·
Global Moderator
Joined
·
13,110 Posts
wd40. If your adventurous, you might try greasing the pivot points of clutch and brake pedals. This involves disassembling them. They probably haven't been greased since they were built.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
Dumbasses the second - Problem Solved

Guys this is unbelivable. First I had a light wrong in the Ashtray and today this:

I was going down the road today, to work with my buddy on the Firebird. I came to a redlight and WHAM ! Something broke when I pushed the clutchpadal. :werd:

I turned the hazzardlights on, arrived and my friends house, we checked it out, and...there was an extra spring, that automaticly brought the clutchpedal back in position :eek::craz28:

So they way it looked like, somebody customized that crap to drive on the clutchpedal or whatever. Of course after a while a shit job like that messes up the clutch, and that was the first thing, I replaced in my car and nobody knows where it came from. I know now. The bucking like a horse, the funny RPM in the parkingspots....all makes sense now. First the lighted ashtray and then this :craz28:

But no other problems and nothing broke, my mechanic checked it twice...what broke, was the cheep crap job they did. Thank god, that is behind me....

Lars
 
1 - 3 of 3 Posts
Top