LS1LT1 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 · (Edited)
A few weeks back while driving home, my car didnt want to go into any gear any more. So i let it ride on neutral and made it home by a few feet. So, the next day i checked the aster slave, & it had no pressure. So, i bled the slave, & put it back on. Still wouldnt go into gear, so i did it again & found shaving. So, i just decided to change the clutch. Finally i get the chance to do it today. Everything goes well, i took the transmission off easily. Then, changed the clutch, & put the transmission back on. Finally, i "adjusted" the clutch fork. To me it set it with the click. So, i thought it was fine.

Finally my brother tells me to put the slave back on. ( which worked fine) Then he tells me to pump it, but i tell him not till were finished. Till he washed my head & i did it. So, i pumped it 2 times slowly, & for the 3rd one the slave snapped & the clutch fork got stuck all the way to the bottom. Like going toward the engine. After, we go under and take out the slave & try to pop out the clutch fork. But it was/is super stuck. So we take off all the bolts again, & tried to take out the transmission. But the transmission didnt move at all.

Finally, i gave up. The tranny didnt come loose at all. ( yes all the bolts were/are off) I dont know what to do or how to take it out.
 

·
Registered
Joined
·
157 Posts
are you sure you put the retaining clip in for the throwout bearing? did you replace the pivot point on the clutch fork?

to me it sounds kinda like the base the fork pivots on snapped and wedged the fork against the inside of the bell or on the pressure plate.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #3 ·
Well not sure.if i did, because.the.throwout bearing was on the clutch. As for the pivot point, i did replace.it.

Im.sure.its.under the.pressure plate. Would you happen to know a way to.get it out?
 
1 - 4 of 4 Posts
Top