LS1LT1 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi im need some serious help i recently purchased a 94 z28 when i bought the car wouldnt start . Fixed thr problem it was 2 wires under thr dash that some one had cut . Recently i was at a friends went out to go home car wouldnt start no crank nothing lights came on radio worked but no guages or anything this is a 350 lt1. Replaced starter cause it froze up had someone look at it and they disconnected 2 white wires that ran to a connecter that connected to a yellow and brown wire and i believe to be another brown wire. The connecter was broke apart ... i no its not smart on my end but im a single mom trying to get by and the so called " mechanic " was an idiot. So if anyone could help me on what to do i would apreciate any input .. and please explain in girl terms because im no mechanic but i do no a little about some cars but clueless on this motor .. thank you for taking the time to read this..
 

·
Global Moderator
Joined
·
13,109 Posts
I hate to tell you this but you are going to have to learn about cars. You seem to have wiring problems which will require you to know how to read wiring diagrams.

Go to the following site and download the 94 factory service manual. It has everything about your 94 in there. My Files.

Next is a trip to your local library for books on auto repair basics. I believe there's an Idiots guide to auto repair out there. You need to have a basic understanding on how a car works.

Telling us a brown wire is broken, tells us nothing. There are a bunch of brown wires of various wire gauges on the car. As well as wires of about every other color. You might want to take pics of the connectors that are bad. We can many time determine what the wires are from where they are located on the car.

But again, you being a single mom with no one to depend on, makes it necessary to get the knowledge you need to depend on yourself.
 
1 - 2 of 2 Posts
Top