LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Ive got a 92 rs with a lt1 from a 94 z28 that I'm in the process of getting tuned. Last Saturday I was data logging and came to a stop and the engine stumbled and died.

It does that occasionally because the tune is still off but it threw codes 16 41 and 51. It started back and did fine the way home. Then this morning it did the same thing except it three just code 16 but it started back up and did fine the way to work.

It runs fine and the optispark only has 750 miles on it. Any ideas? I have to take a long trip Saturday and I'm worried it won't make it. Thanks
 

·
Global Moderator
Joined
·
13,121 Posts
Since your getting an intermittent dtc 16, opti low resolution pulse missing, I'd take another vehicle on your trip.

Did you install a new opti pigtail wiring harness when you bought new opti? If no, buy a new pigtail and see if that solves problem. Bad wiring & connectors can cause codes to set.

If you plan on keeping your 92 rs for awhile, buy a pc based oscilloscope to test low & high resolution signals from opti. Scope is only test instrument that will show the actual square waves of low & high res signals. Good for testing fuel enable 30 hertz signal also.

Buy pc based scope on Ebay, Amazon, etc for around $70. If your new or rebuilt opti is anything but a GM, Delco, or Delphi, you have a high chance of it failing quickly. Your problem could be wiring pigtail. Or it could be the beginning of optical failure of new opti.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
What doesn't make sense is it's never done it driving down the road, it's always directly after coming to a stop. I've got a new pigtail I could try and if not I'll be installing a msd opti.
 

·
Global Moderator
Joined
·
13,121 Posts
Be careful with Msd opti. They were having trouble with them a while back. Don't know if they ever solved the reliability problems they were having a few years ago.
 

·
Registered
Joined
·
496 Posts
No apparent problem with mine so far the last few years.

Note: I have stalled the car a few times whilst playing and logging and had some of the DTC’s appear. I suspect they appear because the opti signals come to a stop due to the stall rather than an actual fault on the opti itself

Mitch
 
1 - 5 of 5 Posts
Top