LS1LT1 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hello folks, barney8800 here, bought my wife a 94 firebird trans am a while back as her little hot rod it has the LT1 with an automatic sweet little car and she loves driving it. the engine quit on her one day and after doing some checking found that the distributor went bellie up. put an MSD dist and coil in it, car started up straight away but would not idle I changed all the usual suspects, idle air control, throttle control sensor, map sensor etc, still won't idle. Car starts fine, will idle normal for about a minute and then the idle starts surging by that I mean it will idle normal and then surge to about 1500 and then back to normal. It will do this continually until you shut it down. When I put the dist and coil on I didn't touch anything else. Anyone have any thoughts on what might be the problem or what I should check next??
Would very much appreciate any help or suggestions...........new guy
 

·
Global Moderator
Joined
·
12,988 Posts
Welcome to the forum.

Before changing anymore parts, you need to put car on an obd 1 scanner that does real time sensor data.

First check for codes as the 4 ignition biggies don't light the check engine light. If codes present, go to following link and download the 94 service manual. It will have full list of codes. What makes them set, & what pcm does when they set. And troubleshooting.

www.mediafire.com/?40mfgeoe4ctti

Also do a running sensor scan. If you haven't a clue about sensor data, PM me with your email address. I'll send you the pdf file called "scanner readings and what they mean"
 
1 - 2 of 2 Posts
Top