LS1LT1 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hey I recently purchased a 93 trans am it came with a list if mods with apparently included headers. Air intake. Muffler/exhaust EPROM chip 3:73 gear. Aerofoil 26lb Injectors 160 tstat misc other items long story short the car runs great but I really don't feel that the car has any 'balls' on acceleration I bought the car from an older gentleman so carbon may be an issue? How can I clean her out or at least utilize these mods to my advantage
 

·
Registered
Joined
·
763 Posts
What do mean by the car has no balls? Is the car sluggish when you hit throttle? Will the car spin the tires? Power has different meaning and levels to different people.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Sorry for being so vague. I've had a few f bodies with less addons. Off the line seems like it doesn't wanna go. Midrange when I floor it just doesn't put me back In my seat like it should
 

·
Registered
Joined
·
620 Posts
Okay first off, exhaust . If ur exhaust is one of those tight mufflered flow masters then thats being very restrictive on your car with those headers.
Also , what do u mean NO balls?
Also You May need a tune to get it running right with those headers.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
I'm pretty u just described my exhaust exactly. As for tuning. How the heck do I do that. I also notice that my fans runs a lot maybe even all the time. I assumed that was cause of the 160 tstat. The car came like this and I have no means of contacting the original owner who did all the work. On that note what'a the EPROM chip do?
Thanks a lot for the help
 

·
Registered
Joined
·
620 Posts
Okay so here's what im thinking then as to why your car has "No Balls"
So first off, that Eprom chip is something that is used to tune your car in a way, also to save settings on. That type of chip works even when your car ISNT on. Im assuming that since your Fans run a-lot that, that chip is making them come on sooner because of that 160 degree thermo. Its keeping your engine cooler, bcuz colder air = better horsepower gains.
You have a Cold air Intake, 160 degree thermo with the fans tuned to come earlier then factory settings, also you have headers and i Highly restrictive exhaust.
I have read on here on some threads about headers that people constantly state that it is wise to get a tune when you install headers. But I think it would be wise to call up your previous owner (even though you dont want to) and ask him did he tune your vehicle for the headers as well as the fans. If he didnt, then i would suspect your headers with the lack of a tune are the reason why the car seems like it doesnt have alot of umph, and also the restrictive exhaust you have on there.
By the way, do you still have your catalytic converter and how many inches is your exhaust in width/size.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
Hey there. I haven't been under the car yet as I just picked it up and there's still some snow up here. As for the original owner I have no clue how to get a hold of him I bought the car from the second owner who has no clue. Exhaust looks stock except muffler I'm gonna try to see under the car ASAP it's lowered and hard to get under there. How do I tune the car if I have no programmer
 

·
Registered
Joined
·
620 Posts
You cant tune it unless you have a programmer (i dont think)
I dont do electrical components. Theres some great how to's out by tuner cat. But if ur like me and you dont know how, i would let a dyno shop tune it or just get A mail ordered tune that has EXCELLENT reviews and guys on here can back it up.
 

·
Registered
Joined
·
49 Posts
Im not saying that any of the information that has been given is wrong but i have just recently put long tubes on my car. when i purchased it, it already had a flowmaster 40 series muffler on it. (that i plan on changing but haven't yet) also i have not had it tuned yet either do to lack of time. what im trying to get at though is that my car does not run that bad. the headers and 160 thermo made a noticeable difference in power. even tho the muffler is restricting and car hasn't been tuned. the reason why im saying this is because i dont want you to be looking in the wrong spot. it could be the issue in your case but as for me, mine runs like a scalded dog.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #11 ·
Has anyone done the seafoam. If so which is the best way to do it. I've only ever added to crankcase and fuel tank. I'm wondering if carbon is my issue
 

·
Registered
Joined
·
620 Posts
@ perry , gas tank is a good way like u specified.
Do you run 87 octane constantly ?

Idk why , but ive never seen an owners manual for my car and a guy i bought tires from owned several trans ams amd camaros and said they really should have 89 and 93 octane gas in them.
I run 93 and my car runs amazing.
 

·
Registered
Joined
·
1,052 Posts
Just a suggestion new air filter spark plugs and fuel filter time. That should tell internal engine condition better than seafoaming.
 

·
Premium Member
Joined
·
5,014 Posts
i bought a car from an old man before too. he'd never driven the thing further than the closest store, and probably never above 1500rpm.

it idled ok, but lacked power and popped and farted and missed when you floored it up a hill.

out of lazyness, i brought it in to a local shop for a 'tuneup', and the leakdown test was all over the place.. 20%.. 60%.. they said throw the car out.

a top end full of carbon will do that..

one round of seafoam fixed that car right up, and i drove it for years afterwards, it ran perfectly.

if you're thinking of trying it out for the under $10 it'll cost you, go for it... cant hurt to try.
 

·
Registered
Joined
·
620 Posts
I've used it in the gas tank one time and you could tell the car ran more cleaner than it did before, if you really want to do some research on it go below the little headliner where the smaller search bar is and just type in, how to put seafoam in.
But yes you can do it through the break booster hose
 

·
Registered
Joined
·
620 Posts
@ burnzilla, yea i actually looked up eprom on google just now, and some of the reviews arent good.
Not trying to get off topic though.
Perry, did you try the seafoam yet?
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top