LS1LT1 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Ok im just gonna throw thjs one to u guys might luck out..im stumped on the issue and.so is everyone at southbay fuel injectors ok hrre we go ..i ordered a set of 19lbs bosche type 3 fuel injectors with the adapters southbay sells ...i installed them (numerous times ) and when i start the engine is starts a lil rough and bogs out when i give it throttle..(would kill engine if not released in time ) seems like large vacuum leak.

So i put my old injectors back in started it up..ran just fine to eliminate operator error i did this 3 times still ran fine with old ...like c**p with new..i.didnt understand at all..so to narrow it down..i went ahead n cashed in my warrantees on my fpr, fuel filter, fuel pump and o2 (both) as well as sent them back to southbay for testing ..and still no love ...im at a cmolete loss of words here..fuel pressure is low on gauge like 30 (instead of 41-47) and doesnt rasie or drop during driving thts what made me do fuel pump again..made sure the fuel line were clear tested pump before putting back in. Test ed have pressure at shrader valve and a decent amount too..cleared air out of lines re installed fuel injectors again just to be sure and still ...will start with wierd idle and as soon as u give it gas it tries to die ...if u gas it let go fr a sec and gas again will rev up but when from idle trys to die.like it getting too much air..used stethoscope ..injecrors are firing ...putt back in old injectors runs fine...im pullin out my hair

No my old injectors are mismatched 19lbs injectors and 24 lbs injectors (er picked up a few from 5.7 at pick n pull..and at least two out of 8 are leaky ...what i dont get how mismatched leaky injectors run better than a new set of bosch 3 injectors....im so lost...no vacumm leaks ..cheaked everything over three times and still chokes out when i give it gas.....and for some reason the fuel pressure dropps to zero after abut 30 min to an hour ..not leakin fuel at fuel rail or frm intake manifold or frm lines fuel filter pump ect. Wiring has been checked and checked any help would be great
 

·
Global Moderator
Joined
·
13,428 Posts
Have you tested your fuel pressure regulator? First remove vacuum line and see if fuel comes out of it. That's a sure sign of trouble. Next start engine and check fuel pressure with vacuum line off. Is pressure higher with line off? If yes, this is another sign that regulator is bad.

Final test, disconnect fuel return line, place jar to catch fuel, do key on prime. At key on prime, fuel should not be coming out of the return line. If it is, and theres a lot of fuel returning, another sign of a bad regulator as it's stuck partially open.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3 (Edited)
I replaced it twice so shouldnt be bad but good idea i will check tht asap ...heres an update tho...after pcm relearn it runn a lot better ..but fuel pressure is still low i dont understand why. like 30psi is the highest...will try ur idea but remember new fuel pump( changed twice.).new fpr (changed twice) new fuel filter changed twice...have two. New ones so have tried bavk n forth too ..and new injectors and double bench tested by southbay fuel lines clear ..i blew thew them ..all three ..fuel rail is clear ..and on last install
I put pump in fuel tank and hooked it up.. tested it....worked hooked up to in fuel line1 Tested it ...worked ..put filter on tested..worked ..hooked up to fuel line to ...tested it under hood ..worked..hooked up to fuel rail. Tested..ran extra air in rail through shrader valeve until good spray ..runns about 30 psi. ...when u hit the throttle it put puts almost dies but if u flutter it u get it reving..something isnt right fuel preszure low n about 38u psi with vacuum line to fpr.off and the hose plugged (no vacuum leak) ...but seemed rich ..if i leave vacumm line unplugged it seem to give just enough air to even out o2 sensors n runn lil leaner bug lacks pick up from the leak ..the kicker is even with the leak n lost accel. It still runs better then everything. Hooked up properly.. has three inch dual exhaust.. cats.. no muffler..and when i revv it up and lett go it ppops twice almost like gun shot...when i started it ..n hit the gas its was like "P..PUT PUT VROOM- GLUGG GLUGG GLUG" til uu let the gas go n flutter it. ...now after gm drive cycle it has evened out for most part..still pops twice loudly on deccel when reved up stil has low pressure and drives like it ..like its starved...ive put old injectors back in and runs fine doesnt skip a beat..but leak like a siv and still drives better then now...im thinkin my pcm is having an issue and the fuel pressure being low makes me thing its making up em spray too long or something
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
Ok so just did what u said and un hooked return fuel line n turned to "on" and it shot out like it did when i tested fuel pump at the tank ...lil to no resistance..alot of fuel..and hooked it all back up n switched to "on"and check shrader valve and next to no pressure in rail on prime..mabe a smal squirt so the second new fpr bad too?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5 (Edited)
Ok so new fpr tommorow again and will checl bak with results...now tht i think of it ..the car does act the same as it does when its runnin outta gas and would explain a good portion of the popping ..i think
 

·
Global Moderator
Joined
·
13,428 Posts
Yes, when you do key on prime, with engine off, regulator should be completely closed. There will always be a tiny bit of return to the tank, that is why fuel pressure will normally bleed down after several hours. But that's just a tiny bit of return. Your getting a flood of fuel going back.

I believe you are discovering that just because a part is new doesn't mean it's good. With the prevalence of offshore parts with poor quality control, getting multiple bad parts is now the norm rather than the exception.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7
Ok so got a new one n came home to change it...went to bleed out fuel pressure from valve and it sprayed real hard and took like ten min to bleed it off..engine is runnin quite warm ...i expected feul pressure to be low but is was higher thn normal...is tht because of the expansion from high temps? I would think ...but why would it be so high now ( as if it is restricting fuel rather then bleeding it) just last night it wouldnt hold barely at all
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
And stiill bleeding off air now...will completely bleed off but then wait a few min and air pressure builds up...so just a learning question ...would a secondary way to releive fuel system pressure be to apply vacumm to tge regulator n let bleed back to tank? Seem like it would be more cost effectiv instead of wasting all tht fuel every time pluss would empty the rail of un pressurized fuel? Idk just a thought
 

·
Global Moderator
Joined
·
13,428 Posts
You don't normally have to bleed air out of fuel system. In this case, use a pressure gauge to see what fuel pressure is reading.

If you have a problem, you might want to check all the fuel lines and vapor lines, to see if all are in good shape and connected to the correct place. Unfortunately, we don't have any b-body service manuals here.
 
1 - 9 of 9 Posts
Top