LS1LT1 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
I have a95 z28, no power at the 12 volt constant wire on the stereo. Headlamp lights inn the mirror don't work, trunk release in the glove box doesn't work.any ideas?
 

·
Global Moderator
Joined
·
13,428 Posts
Just so we are on same page, stereo gets battery power from courtesy fuse #8 in ip fuse box. If fuse is good and stereo is not getting battery power at the orange wire on connector 1 cavity 10, then you need to trace the wiring.

There is a splice in the wire bringing battery power to stereo, splice S210, which is located in wiring about 5 inches from rear defogger switch. That's 5 inches down the wire bundle in the dash.

You never said what the stereo problem is. If you have no constant power, stereo should work but loose presets and time every time it's turned off.

hatch release gets it's power from same fuse as stereo, might be that pesky splice S210 again. Anyway check connector C1 of hatch relay for power. Again it's a orange wire. Relay is located behind instrument panel to the right of SIR bracket.

Since the lights in the mirror get their power from the same fuse as the radio constant power, I would check splice S210 for that problem also. See if you have battery power at the mirror, if no check S210.

Sounds like you might need some wiring diagrams. 94 factory service manual is located in the 4th gen section. Look for thread titled "GM service manuals". 94 shares most info with your 95. You'll find wiring diagrams in volume 2.

If you have trouble finding hatch release relay or S210, right after wiring diagrams in manual will be a component views section, which will show where these are located, in a diagram.
 
1 - 5 of 5 Posts
Top