LS1LT1 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
My 97 firebird trans am had problems yesterday due to the heavy rain &freezing ice ,it drove fine leaving from work,but it started to misfire,( my check engine light would flash) it puddered and vibrated sitting at stop lights,I thought that it was gonna stop running, but it made it home.After a while I went to start it up to see if anything changed for the better,Nothing. A few hours later my wife called me from her job because she locked her keys in her car,so I came out with the spare key,car ran fine there and back (the rain had slacked up alot by then) could the rain have something to do with this? I'm puzzled but not worried,I love this car and will get it fixed at any cost. Please someone give me some advice because I'm new to lt1's.
 

·
Premium Member
Joined
·
5,014 Posts
you'll have to do some checks (find out what that check engine light is, for starters)

moisture and igntion systems don't get along

probably the opti, though. it might clear up.

if there's a whole bunch of condensation in the air, some of it can get drawn into the opti vent tube (or into the opti itself, if the seals are poor). sometimes once that moisture vacuums itself out, it's ok again. but i bet there's an opti replacement in your future.

if your spark plug wires are bad, and they get covered in moisture, they can arc and misfire as well...
 

·
Registered
Joined
·
449 Posts
I know when it would rain or be alot moisture in the air mycar would run like crap. The thing is ur optis vented when mine isnt. See if u can retrieve the codes that came up
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #4 ·
reply

Yeah,I plan to replace optis,plugs,& wires.It's doing fine since it hasn't rained in a day or two ,but I know it will do it again,so the next time it rains I won't drive it.thanks guys I'll put up another post when I get these things taken care of. Oh,I priced an msd optispark and rotor set for 151.00 at advance autoparts,its not vented,Is this a good brand to use?
 

·
Registered
Joined
·
807 Posts
Yeah,I plan to replace optis,plugs,& wires.It's doing fine since it hasn't rained in a day or two ,but I know it will do it again,so the next time it rains I won't drive it.thanks guys I'll put up another post when I get these things taken care of. Oh,I priced an msd optispark and rotor set for 151.00 at advance autoparts,its not vented,Is this a good brand to use?
Usually a new MSD optispark sells for about $400, so either you are getting a great deal, the guy at the parts counter made a mistake,or
its some knock off MSD like distributor. Check ,but hurry if you are serious, I believe Summitt is having a close out on genuine new GM
Optis for $150 ,from what I have heard from the other guys , this is legit. And I would say if your car responds poorly to damp weather its almost always electrical in nature, plugs , plug wires or distributor. ed
 

·
Registered
Joined
·
471 Posts
Yeah,I plan to replace optis,plugs,& wires.It's doing fine since it hasn't rained in a day or two ,but I know it will do it again,so the next time it rains I won't drive it.thanks guys I'll put up another post when I get these things taken care of. Oh,I priced an msd optispark and rotor set for 151.00 at advance autoparts,its not vented,Is this a good brand to use?
Guy at advance probably quoted you a cap/rotor kit not an actual distributor so i would ask him again to be sure

Sent from my SPH-D710 using AutoGuide.Com Free App
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #8 ·
Yeah it was a kit,the msd opti costs 529.99 I'm gonna shop around a little to see if i can find one cheaper.
 

·
Registered
Joined
·
366 Posts
i was gonna say its most definitely something to do with the ignition but it seems like you've got it figured out now

had the smallest crack once in my old caprices dist. cap and it ran like you explained in heavy rain, it was so bad that i literally had to floor it to keep it going down a 25mph road, good thing i lived 5 mins from work that day haha
 

·
Registered
Joined
·
132 Posts
My LT1 was doing this about a month ago after a heavy rain. Some days would run fine then some days would run like crap and stumble around in idle at a red light some days it would come and go. I changed the plug wires and it did not help any. Seems to have cleared up now as it has not done it in a couple of weeks. I've only had car a little over a year and have already put 3 Opti's on it (cheap ones). I'm about to switch to the LTCC coil pack conversion myself. Besides I'm adding some nitrous down the road and the LTCC timing retard feature will suit that perfect.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #11 · (Edited)
I'm gonna order my opti from summit racing for 249.00,I have to wait till my next pay period (don't have alot of cash lying around,I live from paycheck to paycheck) to get it.They have some on clearance for 199.00, but I don't think they will still have them by the time that I'm ready. Thanks guys you all are a great help to me,This forum is the best,glad to be a member.
 
1 - 11 of 11 Posts
Top