1999 Firebird 3.8 Misfire Problem - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-29-2013, 07:02 PM Thread Starter
Regular Member
 
Join Date: May 2013
Location: New Jersey
Posts: 3
 
1999 Firebird 3.8 Misfire Problem

About a week ago I starte having misfire problems with my firebird. It came up as a bad coil so I replaced. The problem stopped for a day now I have a misfire again. Is there any tests I can do at home without spending much money?



I'm sort of a newbie mechanic, I know general terms and can fix things if pointed in the right direction.
TJ406 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-09-2013, 07:10 PM
96z
Regular Member
 
Join Date: May 2013
Posts: 21
 
oh it happens alot with those. Im assuming your motor was a pick n pull from the graveyard, alot of those need new plugs. i would pick up a set of ngk irdiums if anything.
96z is offline  
post #3 of 3 (permalink) Old 07-09-2013, 07:57 PM
Regular Member
 
Project96's Avatar
 
Join Date: Sep 2009
Location: Clarksville, Tennessee
Posts: 213
 
I had the same problem with my camaro. 2 coils later & an icm & it was fixed.

Sent from AutoGuide.com Free App

Red 1994 Trans Am Coupe
Red 1996 Camaro RS - T-Top, stock (Y87)
Project96 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome