knocking or tapping - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 09-05-2009, 08:03 PM Thread Starter
Regular Member
 
startrek89's Avatar
 
Join Date: Jul 2009
Location: Detriot Mi
Posts: 50
 
knocking or tapping

I got another 3.8 fbody took it for a spin on the freeway auto trans I'm going 60-75 hi rpms. So i put it n 3 to kick the rpms and my car started slowing down I put in drive it wouldn't do no more than 70mph got home and a ticking/knock or tap started and the oil meter was jump from high to low any ideas? I'm thinking some rod bearings
startrek89 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-06-2009, 12:12 AM
95Z
Admin
 
Join Date: Mar 2008
Location: MD
Posts: 8,048
 
Doesn't sound good. Just noise could be a lot of things, but noise and loss of power along with oil pressue points to a bearing issue. I'd put a mechanical gauge on to verify, but its probably toast



Yep its slow.

Making the world a warmer place one gallon at a time.
95Z is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome