V6 TO V8 SWAP - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 06-29-2009, 06:48 PM Thread Starter
Regular Member
 
keenan's Avatar
 
Join Date: Aug 2007
Location: south , louisiana
Posts: 957
 
V6 TO V8 SWAP

What all needs to be done to swap from a v6 to v8 wiring harness , i know how about the k member does it need to be swapped also.
Swapping transmission also.

Krazy Kajun 95 camaro 383 LTI A4 ,58mm Edelbrock TB,3.73gears,Descreened MAF, Trans go shift kit,4000 stall,b&m cooler,K&Ncai,Tune from Trifecta Performance , LT Headers,CSR water pump.Stage 3 P&P Heads ,Comp. Cams XFI 292 ,1.6 RR's.



keenan is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 06-29-2009, 07:01 PM
Less than 8 cylinder Moderator
 
GTP231's Avatar
 
Join Date: Aug 2005
Location: Dover DE aka Slower Lower
Posts: 4,979
 
Send a message via Yahoo to GTP231
What V6 to what V8. If its a LSx you'll definitely need a K memember but not sure on LTxs

Mr. Black Angus
01 PT Cruiser (beater for now)
03 GTP Stock I swear
13.464 @ 103.51 mph spinning a lil Totaled 9/25/2010
LSx> L67> Cross Fire> LTx
Quote:
Originally Posted by Grims View Post
God said, let there be light, and the optispark was born...and he saw that it was bad.
Quote:
Originally Posted by sweetbmxrider View Post
Lt1's suck.
GTP231 is offline  
post #3 of 17 (permalink) Old 06-29-2009, 08:58 PM Thread Starter
Regular Member
 
keenan's Avatar
 
Join Date: Aug 2007
Location: south , louisiana
Posts: 957
 
Yeah sorry it's LTX

Krazy Kajun 95 camaro 383 LTI A4 ,58mm Edelbrock TB,3.73gears,Descreened MAF, Trans go shift kit,4000 stall,b&m cooler,K&Ncai,Tune from Trifecta Performance , LT Headers,CSR water pump.Stage 3 P&P Heads ,Comp. Cams XFI 292 ,1.6 RR's.



keenan is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 06-29-2009, 10:24 PM
Less than 8 cylinder Moderator
 
GTP231's Avatar
 
Join Date: Aug 2005
Location: Dover DE aka Slower Lower
Posts: 4,979
 
Send a message via Yahoo to GTP231
Mounts might be the same and not need a front end. Not sure about the LTx stuff

Mr. Black Angus
01 PT Cruiser (beater for now)
03 GTP Stock I swear
13.464 @ 103.51 mph spinning a lil Totaled 9/25/2010
LSx> L67> Cross Fire> LTx
Quote:
Originally Posted by Grims View Post
God said, let there be light, and the optispark was born...and he saw that it was bad.
Quote:
Originally Posted by sweetbmxrider View Post
Lt1's suck.
GTP231 is offline  
post #5 of 17 (permalink) Old 08-27-2009, 02:56 PM
ACE
Regular Member
 
Join Date: Jan 2007
Posts: 14
 
anyone know

i changed a 3.4 L for 5.7 L lt1 into a 95 camaro from a 95 firebird rage top RIP 07/22/08. But anyway's i used the computer land harness allso had to fab the driver side motor mount an i used a three speed trany 350 turbo with a shortend drive shaft.Ran great at first but now it has a splutter to it and i think it's the fuel pump or the mas IDK
ACE is offline  
post #6 of 17 (permalink) Old 08-27-2009, 09:24 PM
Regular Member
 
startrek89's Avatar
 
Join Date: Jul 2009
Location: Detriot Mi
Posts: 50
 
For f-bodys an ltx get the computer w/harness and rear gear changed I'm putting an lt1 in my v6 firebird everything bolts right up or if you want more get a real grandnational motor/trans and w.harness you might need a computer too if you do that you would have one of the fastest f-bodys around
startrek89 is offline  
post #7 of 17 (permalink) Old 08-27-2009, 10:25 PM
ACE
Regular Member
 
Join Date: Jan 2007
Posts: 14
 
DO you know what exactly needs changed? on the DLC
ACE is offline  
post #8 of 17 (permalink) Old 08-28-2009, 10:34 PM
ACE
Regular Member
 
Join Date: Jan 2007
Posts: 14
 
Well i changed the MAS and no change wat so ever and thanks for the tip on the DLC Much appreciated oh and all so where can i get a service book and how much is it if you know
ACE is offline  
post #9 of 17 (permalink) Old 08-28-2009, 10:41 PM
Regular Member
 
startrek89's Avatar
 
Join Date: Jul 2009
Location: Detriot Mi
Posts: 50
 
You can get a service book from an autozone/murrays they should cost around 19.99-24.99 make sure you get the one for your year they cover almost everthing you need to know
startrek89 is offline  
post #10 of 17 (permalink) Old 09-01-2009, 10:28 PM
ACE
Regular Member
 
Join Date: Jan 2007
Posts: 14
 
startrek89
Regular Member

Join Date: Jul 2009
Posts: 16




You can get a service book from an autozone/murrays they should cost around 19.99-24.99 make sure you get the one for your year they cover almost everthing you need to know


Those books dont have what i need ALLDATA

95 camaro all stock + A 69 under construction with a 327 auto with a posi trac and duel exhaust
ACE is offline  
post #11 of 17 (permalink) Old 01-15-2010, 01:07 AM
Regular Member
 
Join Date: Oct 2009
Location: Fayetteville, GA
Posts: 287
 
Did you have to change the fuel pump for it to start?
TheReginator is offline  
post #12 of 17 (permalink) Old 09-10-2012, 03:15 PM
Regular Member
 
camaro1991's Avatar
 
Join Date: Sep 2012
Location: GA
Posts: 6
 
Unhappy v6 to v8 need help please

i also have done a v6 to v8 swap and i am stuck im new at this fourm and i have no idea how all of this works. but i swapped my 96 3.8 to a 94 lt1 and i swapped everything i could think of. motor, k member, wirering harness, transmition, drive shaft, computer, gauges, and i have everything hooked up right i would think. well here is my problem. after i got the motor in and everything together i put the key in and the fuel pump didnt cut on and the distributor isnt getting fire. i was told its the chip in my key that i needed to get the right resistance for the new computer so i did that and now nothing at all happens except my security light comes on and my car doesnt do anything ive called the dealership and they have no clue as what im talking about. and i am at the point where im frustrated and idk what else to do or try. do i need a new bcm? a new tdm? what i have no clue someone please help me. any advise will be great. and the lt1 came3 out of another camaro as well.
camaro1991 is offline  
post #13 of 17 (permalink) Old 09-11-2012, 08:48 AM
Regular Member
 
Join Date: Oct 2009
Location: Fayetteville, GA
Posts: 287
 
You have to change you're wiring in the 3 connector harness that comes off of the CPU. Get someone to get you a diagram of those connectors and just splice them together. I had the same exact problem. The sputtering may be the transmission mount, My car was jerking whenever I laid into it out of a turn, it may just be the fuel pump though but I was having the same problem so make sure thats not it, but you will eventually have to change the fuel pump the LPH isn't high enough for the LT1 but the fuel pressure is so it'll work for starting and light driving but once you try to drive it hard you'll have problems. What part of GA?
TheReginator is offline  
post #14 of 17 (permalink) Old 09-11-2012, 11:19 AM
10 Second Opti Club
 
sweetbmxrider's Avatar
 
Join Date: Jun 2009
Location: jersey shore
Posts: 6,736
 
Quote:
Originally Posted by camaro1991 View Post
i also have done a v6 to v8 swap and i am stuck im new at this fourm and i have no idea how all of this works. but i swapped my 96 3.8 to a 94 lt1 and i swapped everything i could think of. motor, k member, wirering harness, transmition, drive shaft, computer, gauges, and i have everything hooked up right i would think. well here is my problem. after i got the motor in and everything together i put the key in and the fuel pump didnt cut on and the distributor isnt getting fire. i was told its the chip in my key that i needed to get the right resistance for the new computer so i did that and now nothing at all happens except my security light comes on and my car doesnt do anything ive called the dealership and they have no clue as what im talking about. and i am at the point where im frustrated and idk what else to do or try. do i need a new bcm? a new tdm? what i have no clue someone please help me. any advise will be great. and the lt1 came3 out of another camaro as well.
You still have vats issues. Check out shbox.com and read up on vats.


Quote:
Originally Posted by ShowNoMercy View Post
this is the internet, take it to seriously and you won't get out alive.
http://www.youtube.com/watch?feature...&v=iPMmW3giQQc
sweetbmxrider is offline  
post #15 of 17 (permalink) Old 09-11-2012, 03:55 PM
Regular Member
 
Join Date: Oct 2009
Location: Fayetteville, GA
Posts: 287
 
I don't think it's VATS you swapped the engine harness not the body harness, you HAVE to get the diagrams for the harnesses and swap the wires you need to...it's wiring
TheReginator is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome