LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums - Search Results
Advanced Search
Showing results 1 to 10 of 10
Search took 0.00 seconds.
Search: Posts Made By: The74delra
Forum: General Tech   04-21-2019, 07:07 AM
Replies: 9
Views: 233
Posted By The74delra
Strangely enough I did. I jumped the terminal and...

Strangely enough I did. I jumped the terminal and all I got was 12 over and over and I even used a good scan tool and for some reason could not get it to communicate with the car. Just kept getting...
Forum: General Tech   04-20-2019, 01:44 PM
Replies: 9
Views: 233
Posted By The74delra
Just incase it helps anyone the problem ended up...

Just incase it helps anyone the problem ended up being the cooland temp sensor. It got to the point that the car wouldn't even start just sputter and poor out raw fuel. The first crank with the new...
Forum: General Tech   04-16-2019, 09:45 AM
Replies: 9
Views: 233
Posted By The74delra
Well check for codes. Nothing just keeps blinking...

Well check for codes. Nothing just keeps blinking the 12. I did however while just looking around find what I believe to be a severely dry rotted and maybe collapsing vacuum connector. Does anyone...
Forum: General Tech   04-16-2019, 07:30 AM
Replies: 9
Views: 233
Posted By The74delra
10 4. I'll give it a scan. Wasnt aware a code...

10 4. I'll give it a scan. Wasnt aware a code could be stored without setting off the ses.
Forum: General Tech   04-15-2019, 09:03 AM
Replies: 9
Views: 233
Posted By The74delra
Probably a good place to start was hoping someone...

Probably a good place to start was hoping someone more familiar with the lt1 platform may have noticed a common issue. Thank you
Forum: General Tech   04-14-2019, 02:45 PM
Replies: 9
Views: 233
Posted By The74delra
Rich on start up

So my 93 TA M6 has this problem where it starts up crazy rich. Hard to start sometimes windup feathering the throttle but it always starts but stinks to high heaven and run rough/low idle for about...
Forum: Manual Transmissions | Clutches   02-27-2019, 05:51 PM
Replies: 3
Views: 483
Posted By The74delra
My 93 releases on the higher end of halfway...

My 93 releases on the higher end of halfway through the pedal travel on what I believe is a stock clutch.
Forum: LT1 | LT4 | L99 Engine Tech   01-16-2019, 06:04 PM
Replies: 5
Views: 656
Posted By The74delra
I had a 93 z28 years back and something very...

I had a 93 z28 years back and something very similar happened to me. Tore my hair out for weeks. Ended up being a clogged cat. Don't remember how exactly I figured that out but cut it out and put a...
Forum: PCM tuning & Computer Diagnostics   12-22-2018, 03:30 PM
Replies: 0
  Tuning
Views: 276
Posted By The74delra
Tuning

So I am not pcm tuning guy in anyway shape or form. My car already has headers, a 3" catback, accel ignition box, and next weekend will have a 58mm throttle body/CAI/aluminum elbow. My problem is the...
Forum: New User Introductions   12-22-2018, 03:11 PM
Replies: 0
Views: 102
Posted By The74delra
New to the forum and 4th gens

Hello to you all. Just recently picked up a 93 trans am. Edelbrock headers, flow master catback, accel ignition box. M6 with Hurst shifter. I've had close to a dozen third gens this is my first fbody...
Showing results 1 to 10 of 10

 
 
For the best viewing experience please update your browser to Google Chrome