new project 95 z28 m6... - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
Reply
 
LinkBack Thread Tools
post #1 of 26 (permalink) Old 03-11-2013, 09:51 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
new project 95 z28 m6...

first time posting on the site. i have expierience with lt1s and camaros and firebirds and stuff...either way im having an issue with this 95 camaro i just bought and was seeking some advise. For uprgrades it seems to have headers and k&n intake... it seems to runs descent at higher speeds(over 40ish), bug chugs aroound a lil bit taking off....changed the plugs and checked wires ok. seems to be getting plenty of gas just feels like a miss...any leads? has been driven in snow(not by me :p)
youngson616 is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 03-11-2013, 10:01 PM
Regular Member
 
Join Date: Mar 2013
Posts: 30
 
How do you post on this site???????
BrettLT1 is offline  
post #3 of 26 (permalink) Old 03-11-2013, 10:53 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
When you find to the thread of your interest, click new post at the top left corner of the list of
threads
youngson616 is offline  
Sponsored Links
Advertisement
 
post #4 of 26 (permalink) Old 03-11-2013, 10:54 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
it actually says new thread not new post sorry
youngson616 is offline  
post #5 of 26 (permalink) Old 03-12-2013, 12:15 PM
Regular Member
 
Join Date: Mar 2013
Posts: 30
 
Thanks buddy. My car is doing the same thing too. Does it feel like when your about to start off it kinda wants to bog down on you? Is it running rich?
BrettLT1 is offline  
post #6 of 26 (permalink) Old 03-12-2013, 12:31 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
Thanks so much for your response Brett. Yeah I'm expieriencing exactly what you described. I almost wanna blame the optispark, but that's a $350 delco/delphi unit :p. when I changed the spark plugs they smelled like it was burning rich. It was better after but didn't cure the issue. I'm going to change the wires this weekend even though they look okay I'll let you know how it goes...
youngson616 is offline  
post #7 of 26 (permalink) Old 03-12-2013, 01:01 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
does your car have the stock optispark or does it have an MSD or another aftermarket unit?
youngson616 is offline  
post #8 of 26 (permalink) Old 03-12-2013, 01:20 PM
Regular Member
 
Join Date: Mar 2012
Location: stongsville oh.
Posts: 56
 
check this out! Chevrolet Performance Replacement Optispark Distributors 1104032 - SummitRacing.com
I just got 1 for $199.99

95 Trans Am - 355/LE2 heads/cc503/ls1 lifters/scorpions 1.6RR/ Bosch 34#/58mm TB/ k&n cai/pacesetter lt/magnaflow catback/ TCI streetfighter/delphi opti/10.4
michael mize is offline  
post #9 of 26 (permalink) Old 03-12-2013, 01:32 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
Wow what a good deal! Ill be ordering one today thanks for the link!
youngson616 is offline  
post #10 of 26 (permalink) Old 03-12-2013, 01:34 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
Is chevy performance just as good as delco/delphi?
youngson616 is offline  
post #11 of 26 (permalink) Old 03-12-2013, 01:53 PM
Regular Member
 
Join Date: Mar 2012
Location: stongsville oh.
Posts: 56
 
It is delco!! I bought it for a back up, I couldn't pass up that price. I have a new summit brand on there now.

95 Trans Am - 355/LE2 heads/cc503/ls1 lifters/scorpions 1.6RR/ Bosch 34#/58mm TB/ k&n cai/pacesetter lt/magnaflow catback/ TCI streetfighter/delphi opti/10.4
michael mize is offline  
post #12 of 26 (permalink) Old 03-12-2013, 02:46 PM
Regular Member
 
Join Date: Mar 2013
Posts: 30
 
Your welcome buddy and yes please let me know how that goes. Thanks
BrettLT1 is offline  
post #13 of 26 (permalink) Old 03-12-2013, 03:03 PM
Regular Member
 
95 Firehawk's Avatar
 
Join Date: Dec 2011
Location: McDonough, GA
Posts: 562
 
new project 95 z28 m6...

You should do some diagnostics before just changing parts at random that can get costly (although it's not necessarily a bad idea to have a spare opti laying around). Is there any smoke when it's chugging and if so, what color? Have you scanned for codes? There are some big ones that don't light the CEL.

I would start with the things that are easiest to check, like a code scan and testing the fuel system, then move on to ignition issues and data logging. It's difficult to find a place to scan a '95, so some just buy an OBDI compatible scanner and most use Datamaster and purchase the ALDL cable to be able to connect a laptop. For fuel diagnosis, a fuel pressure gauge is necessary and cheap. Ignition components can be checked with a spark tester and by having the ICM brought to you local parts store (bring it hot) that has an ICM tester.

1995 Firehawk #528 resto-mod underway

Planned 383 rebuild: 195cc competition LT4 AFR heads, custom cam grind (still debating specs), 6" or 5.85" rods, forged internals

Upgraded T56: Viper mainshaft and 2nd gear, steel 3/4 shift fork, Billet keys 1-4, bronze shifter cup, internals Cryo'd and REM'd
95 Firehawk is offline  
post #14 of 26 (permalink) Old 03-12-2013, 03:14 PM Thread Starter
Regular Member
 
Join Date: Mar 2013
Posts: 66
 
Thanks Firehawk for your input, I am getting no codes on the scanner. I did compression test on the motor everything checked out there. the fuel pressure was okay too. there is no smoke when it chugs just burns rich
youngson616 is offline  
post #15 of 26 (permalink) Old 03-12-2013, 03:30 PM
Regular Member
 
95 Firehawk's Avatar
 
Join Date: Dec 2011
Location: McDonough, GA
Posts: 562
 
new project 95 z28 m6...

How did you determine it's running rich? You will usually get a puff of black smoke when you mash it if it's rich. You should also be checking O2 operation and LTFT's in a scanner to verify. Excessively rich conditions will eventually throw a code and light the SEL. A quick check of the vacuum hose at the FPR is a good idea to be sure fuel isn't leaking past the FPR diaphragm and into the vacuum line.

1995 Firehawk #528 resto-mod underway

Planned 383 rebuild: 195cc competition LT4 AFR heads, custom cam grind (still debating specs), 6" or 5.85" rods, forged internals

Upgraded T56: Viper mainshaft and 2nd gear, steel 3/4 shift fork, Billet keys 1-4, bronze shifter cup, internals Cryo'd and REM'd

Last edited by 95 Firehawk; 03-12-2013 at 04:51 PM.
95 Firehawk is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome