Headlights go out after 30 min of driving on 94 firebird? - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-15-2019, 01:02 PM Thread Starter
Regular Member
 
Join Date: Oct 2018
Posts: 2
 
Headlights go out after 30 min of driving on 94 firebird?

I am looking for anyone who has had this problem. I have a 1994 25th anniversary edition Trans Am. I can drive if for appox 20 to 40 minutes, then the headlights just go out.
traceybunch is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-16-2019, 07:09 AM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 12,743
 
Light switch has a built in circuit breaker. It is my opinion that circuit breaker is overheating and opening up. This shuts your lights off. When circuit breaker cools down, it's contacts close and lights work again.
cocobolo95 is offline  
post #3 of 4 (permalink) Old 05-16-2019, 09:50 AM Thread Starter
Regular Member
 
Join Date: Oct 2018
Posts: 2
 
Where is the circuit breaker?
traceybunch is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-16-2019, 09:09 PM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 12,743
 
Circuit breaker is built into light switch. If circuit breaker goes bad, you have to replace the light switch.
cocobolo95 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
94 z28 runs good one min crappy next D'Z28 General Tech 12 01-14-2013 08:19 PM
Urgent Loud exhaust after 40 min of driving running really rough after same amount of time B_body beast LT1 | LT4 | L99 Engine Tech 9 11-21-2012 01:31 PM
wont start after a 5 min drive 94 z28 NastyN8 LT1 | LT4 | L99 Engine Tech 51 02-18-2010 08:33 PM
Diesling/hard start after runs for min. LE2 Hawk126 LT1 | LT4 | L99 Engine Tech 1 03-04-2009 02:47 PM
Ne Items I added about 30 min ago dkishton1486 Appearance Mods & Car Care/Detailing 7 10-06-2006 08:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome