Optispark help 97 Z28 - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums
 3Likes
  • 1 Post By cocobolo95
  • 1 Post By Stormyweather
  • 1 Post By cocobolo95
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 07-21-2019, 12:40 AM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
Optispark help 97 Z28

I was racing my car It coughed and stalled Lost ignition woulnt start after the race.
Next day it fired right up drove it home it seemed fine went to go to grocery store and made it a block.
Died It was trying to fire a little bit but no start . got it home pushing fired right up .
Looked for vac leaks The only vac leak was the opti itself with 17 on the vac guage it would not pull any vac
what so ever though the cai hose and can hear it leaking through both hoses when I blow on them ..
But not at other hose
And the one way valves are doing their jobs .
I pulled up the codes on cpu
P100 because I have a rebuilt maf sensor
P1441
1657
1371
I bought a gm rebuilt 19212300 optispark for 65 bucks on amazon
The car fires right up now runs perfect
And and just put a new set of pretty expense plug wires on it.
Any help or insight would be greatly appreciated thanks.
TealHornet is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-21-2019, 12:49 PM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 12,917
 
If you paid $65 for a rebuilt opti, It was not rebuilt by GM, Delco, or Delphi. It is a Cheap China knockoff. You are the latest victim. A rebuilt genuine GM, Delco, or Delphi opti will cost over $300.


So ditch the junk and buy the real deal before it leaves you stranded. And being a lt1 owner, buy a $70 PC based oscilloscope. It is the only 100% way to testing the low & high resolution signals that opti sends out.


And buy a new opti to intake wiring pigtail. Pretty sure your old one is corroded & not making good contact.
TealHornet likes this.
cocobolo95 is offline  
post #3 of 11 (permalink) Old 07-21-2019, 06:39 PM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
I bought a second from GM Parts first.com 308 buck 40 shipping 70 core charge comes with pig tail .
My vap solenoid is in fact bad stuck open could that cause stall?
and the vac leak in opti would have to be fixed anyway right?
and thanks Cocobolo
TealHornet is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 07-23-2019, 06:07 PM
Regular Member
 
Stormyweather's Avatar
 
Join Date: Jul 2012
Location: Washington
Posts: 39
 
Opti is vented via manifold to opti then opti to air inlet before throttle body. And it allways open.

Sent from my LG-G710 using Tapatalk
TealHornet likes this.
Stormyweather is offline  
post #5 of 11 (permalink) Old 07-26-2019, 02:36 AM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
What I realy wanted yo know is If I fix the evap soleniod that is stuck open would I be able to drive car without stalling?
Mine opti sucks air in from cold air intake
I was wondering if the vap solinoid being open was the stall and no start condition?
and on opti that I think has busted cap It doesnt suck through distributor to the cold air intake.
On top of that cr8p I received the new opti reman distributor from GM .
It has 2 inches of edge of cap lip busted out behind the coil wire hole right on top ,
Exposing half to 2/3s of the O ring.
And check this out.
The new opti if you suck or blow though either vac port the vac is realy restricted and dosent pull or push to other vac port.
So I think I have to send it back tomorrow.
Along with chinese knockoff.
so my daily driver is down and I realy need it.
Im losing about 4 pounds of vac through evap solenoid.
Any knowledge on the evap solenoid being stuck open the culprit for the stall no start thing?
would be greatly appreciated thanks.

Last edited by TealHornet; 07-26-2019 at 11:37 AM.
TealHornet is offline  
post #6 of 11 (permalink) Old 07-26-2019, 11:27 AM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
I also have extreme amount of vacume on gas cap the last two times I put gas in?
TealHornet is offline  
post #7 of 11 (permalink) Old 07-26-2019, 11:53 AM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 12,917
 
Evap solenoid being always open couldcause stalling issues by causing a lean running condition.


I believe shoebox site has gas tank venting diagrams. shbox.com


If not then download the 96 service manual at the following link. It will have diagrams of hoses, troubleshooting. You could have a code present also.. www.mediafire.com/?40mfgeoe4ctti
cocobolo95 is offline  
post #8 of 11 (permalink) Old 07-26-2019, 03:10 PM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
Thankyou coco Ill fix or replace the evap solenoid and try running it without new opti.
I just got a hold of them at gm and it will be monday before he gets it to ship to me wed -thurs.
I have to find a job asap got canned for driving a water truck in a hole in pavement because it had no barracades on it
and fingered me for damage to truck instead of foreman and supervisor that made decision to not barracade
and to lazy to walk over behind new curb pick up two used curbstakes pound them in dirt and paint them orange
marking paint that always has a case for lining out their job.
the superintendent drove in a hole the day before LOL
But lifes tough when your on the bottom of pecking order.
Sorry if Im venting.
Thanks coco
TealHornet is offline  
post #9 of 11 (permalink) Old 07-27-2019, 09:16 AM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 12,917
 
Venting is allowed here.

One thing that never changes; the people at the top will always cover their own butt's and blame the expendable ones at the bottom.
TealHornet likes this.

Last edited by cocobolo95; 07-27-2019 at 09:18 AM.
cocobolo95 is offline  
post #10 of 11 (permalink) Old 07-28-2019, 01:13 PM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
Yah Thats the way they steal your unemployment Too.
Im anticipating the new reman being made in mexico going to be sealed up tight like the last.
And not venting because they think its to suck out leaking oil from engine rather than nitric acid gas that corrodes terminals that settles in bottom of distributor cap.
and makes it ark to screw next to rotor and makes the car backfire when you let off gas like last opti.
after cover started leaking.
Im thinking drill three tiny holes in middle plate on bottom where nitric gas settles as per buick video.
so fresh air vents from cai to cap to base of distributor vac inlet As per optispark 2 design?

Last edited by TealHornet; 07-28-2019 at 01:16 PM.
TealHornet is offline  
post #11 of 11 (permalink) Old 07-28-2019, 11:16 PM Thread Starter
Regular Member
 
Join Date: Feb 2019
Location: Reno Nevada
Posts: 36
 
Double thanks coco
The evap solenoid was service able at least at valve .
twisted back right off just a dot of glue star screw and it was out cotton swabbed the blockage on ring seal
and back together with a dot of glue .
It killed the code right away I started it several times doing tester reving and idling
test drove around block several times at operating temperature drove it a couple miles to grocery store
so far so good at least I have a runner.
Ill adress the opti when it comes but at least I can go job hunting
Thanks again coco
TealHornet is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome