Urgent failed smog help - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums

Welcome to LS1LT1.com/LS3forums.com - please click here to register...

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 02-25-2013, 03:06 PM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
failed smog help



Can any one let me know what I should look at out of no where check engine light is on with code 26 and 28 please help its a 93 z28 with m6
louisiana93 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 02-25-2013, 03:50 PM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 11,841
 
Did you change your oil right before you went to test? That can work wonders with the HC numbers you get on the test.

shbox.com has a list of dtc's for our lt1 cars. 93 has different 26 & 28 than other lt1 cars that are obd1.
cocobolo95 is offline  
post #3 of 10 (permalink) Old 02-25-2013, 04:11 PM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
I changed it last week cleaned air filter and did tune up yesterday
louisiana93 is offline  
post #4 of 10 (permalink) Old 02-25-2013, 08:54 PM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
so today i sea foamed it and put ne tps and reset the battery now on wendsday i will replace the egr and o2 now unless my car starts acting up lol
louisiana93 is offline  
post #5 of 10 (permalink) Old 02-25-2013, 09:29 PM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 11,841
 
Good luck passing the test on the retry. If you happen to need wiring diagrams to figure something out on your 93, most of them are available for download at BBB Industries- Premium Alternators, Starters, Power Steering Products
cocobolo95 is offline  
post #6 of 10 (permalink) Old 02-26-2013, 10:13 AM
Regular Member
 
Join Date: Mar 2008
Location: Atlanta, GA
Posts: 1,298
 
Code 26 (QDM #1) monitors three circuits, it says ECM does not see correct voltage on EGR Solenoid OR on EVAP solenoid OR on Air Pump Relay. Are they all installed, connections clean, fuses good and wiring intact. Code 28 (QDM #2) monitors two circuits says ECM does not see correct voltage on Fan Relays OR on A/C relay , check wires, connections, fuses, same as above. Your NO reading at 15 MPH was very close to failing with a 674 that indicates "possible" EGR problem . The code 28 will not effect emissions unless car is very hot (over 250* F) during test. High HC is usually a dirty/rich burn caused by what coco has mentioned. Also fouled plug, bad spark, HV wire shorting, O2's bad, worst cast low compression, top end problems, etc. Seafoam in intake may help clear fouled plug(s) or top end crud. What did you do/change in the 'Tune Up' that you mentioned in post #3. Also when tested, was the car hot enough for your non-heated O2's to be working correctly, keep it running while waiting. Do you have any mods ?

I'm Bob.. 1994 Z28, A4, Stall, CAI, Cam, RR's, 342 rear, LT's , CatBack, Tuned

Last edited by bobdec; 02-26-2013 at 10:22 AM.
bobdec is offline  
post #7 of 10 (permalink) Old 02-26-2013, 01:29 PM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
Thanks for the replys.. my car is stock and I changed spark plugs, wires, map sensor, tps, and sea foamed... I ran it on the freeway for a good 30 min and drove intown for about 25.. and left it running while waited so now thursday I plan on doing a egr and o2...I do however have my fans set to a manual switch could that be throwing a code
louisiana93 is offline  
post #8 of 10 (permalink) Old 02-26-2013, 02:49 PM
Regular Member
 
Join Date: Mar 2008
Location: Atlanta, GA
Posts: 1,298
 
Fan code will set if ECM sees ground on fan relay (fans on) when it is not commanding them on. It will not effect emission testing.
As far as the EGR... W/key on engine off (or running at idle) you should have +12 volts on both wires to the EGR solenoid. The brown is +12 v from the fuse the gray wire goes back to ECM and will go to 0V when ECM commands ERG on. However the gray wire s/b +12 volts when ECM is not energizing EGR and the ECM does not energize EGR at idle. If voltage checks are OK then continue.. W/engine idling tap into the gray wire with a straight pin or similar and jump the pin to chassis ground, the solenoid should pick (click on), the EGR valve should energize AND the idle should change to running rougher if EGR valve is working and the EGR exhaust ports are not clogged. Here is a write up ref shbox.com on EGR.. http://shbox.com/1/4th_gen_EGR.html

I'm Bob.. 1994 Z28, A4, Stall, CAI, Cam, RR's, 342 rear, LT's , CatBack, Tuned

Last edited by bobdec; 02-26-2013 at 03:05 PM.
bobdec is offline  
post #9 of 10 (permalink) Old 02-27-2013, 10:24 AM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
ok so today i hope to get off early and take car of the egr...and o2 now how to check the air pump relay are you talking about the pump for the ac because ac works perfect.. and also the evap solonoid what will i be looking for there... thanks again for the help
louisiana93 is offline  
post #10 of 10 (permalink) Old 02-27-2013, 10:25 AM Thread Starter
Regular Member
 
Join Date: Feb 2013
Location: California
Posts: 11
 
o by the way when i changed the tps was i supposed to do anything special to it other tthan just bolt it up because now when cold its hard to start like i pulled the battery cable
louisiana93 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome