accel 300+ ignition on lt1 - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums

Welcome to LS1LT1.com/LS3forums.com - please click here to register...

 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 09-06-2010, 08:43 PM Thread Starter
Regular Member
 
BoneStock95Z's Avatar
 
Join Date: Jul 2010
Posts: 936
 
accel 300+ ignition on lt1

anyone running an accel 300+ race ignition instead of a msd 6AL on their LT1??? and is the install easy?

95 z28 a4, 3500lbs race weight, Moroso CAI, 1LE elbow, free mods, 1.6 nsa RR, 7/16 studs, guideplates, hardened pushrods, cutout after the cat. Current 1/4 mile:13.47 @ 102.56 mph Corrected time: 13.39 @ 103.65 mph Goal:12.5 with bolt-ons.
BoneStock95Z is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-06-2010, 08:46 PM
CKJ
Guest
 
Posts: n/a
I'm running one on one of my cars. It is very easy to install, real plug in play, should be a breeze as long as you have the direction.
post #3 of 12 (permalink) Old 09-06-2010, 10:44 PM Thread Starter
Regular Member
 
BoneStock95Z's Avatar
 
Join Date: Jul 2010
Posts: 936
 
did you have to get a harness to switch it over? mine is the 85-97 one and online it says i might need something to adapt it to my car. what is your parts number? and does it help hp/responsiveness?

95 z28 a4, 3500lbs race weight, Moroso CAI, 1LE elbow, free mods, 1.6 nsa RR, 7/16 studs, guideplates, hardened pushrods, cutout after the cat. Current 1/4 mile:13.47 @ 102.56 mph Corrected time: 13.39 @ 103.65 mph Goal:12.5 with bolt-ons.
BoneStock95Z is offline  
post #4 of 12 (permalink) Old 09-06-2010, 10:48 PM
CKJ
Guest
 
Posts: n/a
I'll tell you the honest truth I have almost forgotten I have it. I've had the box on my car for almost 10 years now. I just hooked up everything that came in the box on my 94 Z28. I couldn't tell you if I noticed a difference or not because I did plugs & wires at the same time so there was a total initial difference but I can't pinpoint hp gain/responsiveness on just the spark box.
post #5 of 12 (permalink) Old 09-06-2010, 10:56 PM Thread Starter
Regular Member
 
BoneStock95Z's Avatar
 
Join Date: Jul 2010
Posts: 936
 
ok thanks. there was an article in some magazine that said the accel provides like 1 more hp and 2 more ft/lbs of torque than the msd box. im not sure how accurate that is but i know the msd looks better lol. ill try to get it on my car asap and see how it does. i should buy some wires soon also but idk if i really want to go through all the hassle. stupid tight space on the lt1 is kind of intimidating sometimes

95 z28 a4, 3500lbs race weight, Moroso CAI, 1LE elbow, free mods, 1.6 nsa RR, 7/16 studs, guideplates, hardened pushrods, cutout after the cat. Current 1/4 mile:13.47 @ 102.56 mph Corrected time: 13.39 @ 103.65 mph Goal:12.5 with bolt-ons.
BoneStock95Z is offline  
post #6 of 12 (permalink) Old 09-07-2010, 12:24 AM
Regular Member
 
Viper's Avatar
 
Join Date: Jul 2010
Location: New Mexico
Posts: 1,052
 
Viper is offline  
post #7 of 12 (permalink) Old 09-07-2010, 10:15 PM Thread Starter
Regular Member
 
BoneStock95Z's Avatar
 
Join Date: Jul 2010
Posts: 936
 
thats with the 96 or 97 ignition. idk if the 95 is worse but it should be a lil more responsive right?

95 z28 a4, 3500lbs race weight, Moroso CAI, 1LE elbow, free mods, 1.6 nsa RR, 7/16 studs, guideplates, hardened pushrods, cutout after the cat. Current 1/4 mile:13.47 @ 102.56 mph Corrected time: 13.39 @ 103.65 mph Goal:12.5 with bolt-ons.
BoneStock95Z is offline  
post #8 of 12 (permalink) Old 09-07-2010, 10:23 PM
Whistles go Whoooooooooo
 
ShowNoMercy's Avatar
 
Join Date: Feb 2008
Posts: 16,469
 
I would not look for the box to give you any at all seat of the pants power, but it will provide you with a stronger spark and rev limiter. Both are very helpful later on when you have it modded a bit more.

Una salus victis nullam sperare salutem

If it ain't ARP, it ain't right.
Quote:
Originally Posted by sweetbmxrider View Post
I have a heavily modified lt1.


https://www.facebook.com/pages/The-U...30966313667982
ShowNoMercy is offline  
post #9 of 12 (permalink) Old 09-07-2010, 10:30 PM Thread Starter
Regular Member
 
BoneStock95Z's Avatar
 
Join Date: Jul 2010
Posts: 936
 
thats true. i mean a stronger hotter spark will help fuel mileage a slight bit atleast. i cant wait to actually do half the junk i wanna do to my car

95 z28 a4, 3500lbs race weight, Moroso CAI, 1LE elbow, free mods, 1.6 nsa RR, 7/16 studs, guideplates, hardened pushrods, cutout after the cat. Current 1/4 mile:13.47 @ 102.56 mph Corrected time: 13.39 @ 103.65 mph Goal:12.5 with bolt-ons.
BoneStock95Z is offline  
post #10 of 12 (permalink) Old 09-09-2010, 12:53 PM
Regular Member
 
JSK333's Avatar
 
Join Date: Jan 2008
Location: Cincinnati, OH
Posts: 977
 
I installed one with the optional timing retard module for my nitrous kit, and it worked fine. However, I believe it went bad after a couple of years.

The car died in the middle of the road, I had it towed and ended up doing a cam upgrade as an excuse, because I thought it was the opti. But the shop told me that it wouldn't start until they bypassed the Accel... so it may have been the culprit the entire time, not the opti! Oh well, still got a new cam out of the deal.

I've also heard bad things about Accel optis (after I bought mine, of course), as well as Accel injectors (coming apart, leaking). I don't know if they changed manufacturers or what, because they used to be pretty good. Their plug wires last awhile at least!
JSK333 is offline  
post #11 of 12 (permalink) Old 09-09-2010, 04:04 PM
Rob
Regular Member
 
Join Date: Aug 2005
Location: Diamondhead, MS
Posts: 440
 
Have one in mine for well over 10 years. Whenever they came out with it. First one lasted less then a year and they replaced it under warranty and that has been in for a long time without any problems.

Rob
04 GTO
08 GXP
96 WS6(sold)
Rob is offline  
post #12 of 12 (permalink) Old 09-09-2010, 04:10 PM
Regular Member
 
Join Date: Aug 2010
Location: Las Vegas, NV..and hatin every minute of it. I want to go home to Oregon!!!
Posts: 29
 
WS6. com, I had completely forgotten about that site!! If you read on the front page about the motor letting go, I had oil on my windshield from that, as I was directly behind him.
almost 10 years later, that car is still sitting in the garage with the same blown motor in it...

James
'95 T/A, M6, Ttops
LVZ2881 is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome