need some advice dammit - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums

Welcome to LS1LT1.com/LS3forums.com - please click here to register...

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 04-17-2010, 12:19 PM Thread Starter
Regular Member
 
Join Date: May 2009
Location: ARUBA
Posts: 603
 
need some advice dammit

if i pressure wash my lt1 and it has dyna spark opti...wil that be trouble???


i need some serious beer intake...dammit
5.7orNOTHING is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-17-2010, 12:35 PM
Yo!
 
R3DLT1's Avatar
 
Join Date: Aug 2008
Location: Oklahoma Bartlesville
Posts: 8,172
 
When i power wash my engine i leave the car on and try to put something over the opti just incase

R3DLT1 is offline  
post #3 of 6 (permalink) Old 04-17-2010, 12:38 PM Thread Starter
Regular Member
 
Join Date: May 2009
Location: ARUBA
Posts: 603
 
Quote:
Originally Posted by R3DLT1 View Post
When i power wash my engine i leave the car on and try to put something over the opti just incase
but i wont start the car for over a week...will that still be problem??
5.7orNOTHING is offline  
post #4 of 6 (permalink) Old 04-17-2010, 12:56 PM
CKJ
Guest
 
Posts: n/a
Any optispark is still prone to failure due to moisture. I personally wouldn't put water near it.
post #5 of 6 (permalink) Old 04-17-2010, 12:58 PM
Regular Member
 
BLACK HAWK's Avatar
 
Join Date: Aug 2009
Location: Earth
Posts: 1,109
 
^^ i'm with the boss...

`````
Former owner of one of the most powerful firehawks known to man.. 95/584 ..she will be missed and not forgotten.. May her new owner treat her well and not wrap her around a tree
BLACK HAWK is offline  
post #6 of 6 (permalink) Old 04-17-2010, 04:14 PM
Regular Member
 
shoebox's Avatar
 
Join Date: Aug 2006
Location: Little Rock, AR
Posts: 6,260
 
I would not pressure wash any LT1 engine bay. If I did wash it, I would start the engine immediately and drive it around to dissipate any moisture. I sure would not let it sit for a week.
shoebox is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome