Urgent 94 z28 wont stay running - LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums

Welcome to LS1LT1.com/LS3forums.com - please click here to register...

 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 01-07-2013, 09:35 PM Thread Starter
Regular Member
 
Join Date: Jan 2013
Location: Texas
Posts: 4
 
94 z28 wont stay running

Hi everyone im new here an ive been having a few problems. I bought this car a few months ago with a bad fuel pump. Replaced it an car ran fine, then it started to take a long time to start an it would cut off on its on without warning sometimes. Now it will run for about 5 mins an cut off an not start for hours. Mods are cc 503 cam kit minor head work, 1.6 rr, lt4 knock sen, full length headers an pcm tune. Something I just seen was that the driver side header burned through a big wire an idk what it is. Any imput wpuld be appreciated
D.holl is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-07-2013, 09:44 PM
Regular Member
 
steveo's Avatar
 
Join Date: Feb 2008
Location: Vancouver Isl., BC
Posts: 4,953
 
we'll tell you what that wire does, if you tell us what color it is, and what kind of plug is on the end.. that might be important..
steveo is offline  
post #3 of 7 (permalink) Old 01-07-2013, 09:53 PM Thread Starter
Regular Member
 
Join Date: Jan 2013
Location: Texas
Posts: 4
 
it goes to the tb

Last edited by D.holl; 01-07-2013 at 10:06 PM.
D.holl is offline  
post #4 of 7 (permalink) Old 01-07-2013, 10:08 PM Thread Starter
Regular Member
 
Join Date: Jan 2013
Location: Texas
Posts: 4
 
It goes to the tb
D.holl is offline  
post #5 of 7 (permalink) Old 01-08-2013, 11:14 AM
Regular Member
 
steveo's Avatar
 
Join Date: Feb 2008
Location: Vancouver Isl., BC
Posts: 4,953
 
steveo is offline  
post #6 of 7 (permalink) Old 01-08-2013, 05:23 PM
Global Moderator
 
cocobolo95's Avatar
 
Join Date: Sep 2008
Location: Fruitland Park,Florida
Posts: 11,539
 
Might want to download the 94 service manual in this section. It has all the wiring, and a driveability section with all engine controls.
cocobolo95 is offline  
post #7 of 7 (permalink) Old 01-08-2013, 10:57 PM Thread Starter
Regular Member
 
Join Date: Jan 2013
Location: Texas
Posts: 4
 
Explained it to a mechanic an he said it was for the cruise controle. The idle steady rises slowly to top out about at 2200 rpm by itself then it sits there for a couple of seconds an just dies
D.holl is offline  
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the LS1LT1 Forum : LT1, LS1, Camaro, Firebird, Trans Am, Engine Tech Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome